1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 12:48:34 +03:00
openwrt-xburst/target/linux/ar71xx/patches-2.6.28/101-ksz8041_phy_driver.patch
juhosg 2047aafc66 ar71xx: refresh 2.6.28 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17694 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-09-23 17:44:05 +00:00

25 lines
802 B
Diff

--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
@@ -85,6 +85,11 @@ config RTL8306_PHY
tristate "Driver for Realtek RTL8306S switches"
select SWCONFIG
+config MICREL_PHY
+ tristate "Drivers for Micrel/Kendin PHYs"
+ ---help---
+ Currently has a driver for the KSZ8041
+
config FIXED_PHY
bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -17,6 +17,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
obj-$(CONFIG_IP175C_PHY) += ip175c.o
obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
+obj-$(CONFIG_MICREL_PHY) += micrel.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
obj-$(CONFIG_MDIO_OF_GPIO) += mdio-ofgpio.o