mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 00:29:41 +02:00
e2e6a5bb07
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22252 3c298f89-4303-0410-b956-a3cf2f4a3e73
32 lines
1.1 KiB
Diff
32 lines
1.1 KiB
Diff
--- a/drivers/input/misc/Kconfig
|
|
+++ b/drivers/input/misc/Kconfig
|
|
@@ -390,4 +390,20 @@ config INPUT_PCAP
|
|
To compile this driver as a module, choose M here: the
|
|
module will be called pcap_keys.
|
|
|
|
+config INPUT_GPIO_BUTTONS
|
|
+ tristate "Polled GPIO buttons interface"
|
|
+ depends on GENERIC_GPIO
|
|
+ select INPUT_POLLDEV
|
|
+ help
|
|
+ This driver implements support for buttons connected
|
|
+ to GPIO pins of various CPUs (and some other chips).
|
|
+
|
|
+ Say Y here if your device has buttons connected
|
|
+ directly to such GPIO pins. Your board-specific
|
|
+ setup logic must also provide a platform device,
|
|
+ with configuration data saying which GPIOs are used.
|
|
+
|
|
+ To compile this driver as a module, choose M here: the
|
|
+ module will be called gpio-buttons.
|
|
+
|
|
endif
|
|
--- a/drivers/input/misc/Makefile
|
|
+++ b/drivers/input/misc/Makefile
|
|
@@ -37,4 +37,5 @@ obj-$(CONFIG_INPUT_WINBOND_CIR) += winb
|
|
obj-$(CONFIG_INPUT_WISTRON_BTNS) += wistron_btns.o
|
|
obj-$(CONFIG_INPUT_WM831X_ON) += wm831x-on.o
|
|
obj-$(CONFIG_INPUT_YEALINK) += yealink.o
|
|
+obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o
|
|
|