1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 17:21:30 +03:00
openwrt-xburst/package/httping/patches/01-honor_includes_lib-paths.patch
florian 0e19261a78 Added support for SSL
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3232 3c298f89-4303-0410-b956-a3cf2f4a3e73
2006-02-13 12:58:34 +00:00

27 lines
874 B
Diff

diff -urN httping-1.0.10.orig/io.c httping-1.0.10/io.c
--- httping-1.0.10.orig/io.c 2006-02-13 13:48:37.645232976 +0100
+++ httping-1.0.10/io.c 2006-02-13 13:48:24.083294704 +0100
@@ -37,7 +37,7 @@
struct timeval to;
fd_set rfds;
- FD_ZERO(&rfds);
+ //FD_ZERO(&rfds);
FD_SET(fd, &rfds);
to.tv_sec = timeout / 1000;
diff -urN httping-1.0.10.orig/Makefile httping-1.0.10/Makefile
--- httping-1.0.10.orig/Makefile 2006-01-02 17:07:29.000000000 +0100
+++ httping-1.0.10/Makefile 2006-02-13 13:44:45.066590304 +0100
@@ -15,8 +15,8 @@
VERSION=1.0.10
DEBUG=-g
-LDFLAGS+=-lssl -lcrypto $(DEBUG)
-CFLAGS+=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
+LDFLAGS+=-lssl -lcrypto $(DEBUG) -L$(STAGING_DIR)/usr/lib
+CFLAGS+=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG) -I$(STAGING_DIR)/usr/include
OBJS=http.o io.o str.o error.o utils.o main.o tcp.o mssl.o res.o