1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 17:21:30 +03:00
openwrt-xburst/package/openser/patches/Makefile.defs.patch
wbx 6175a99e8e ser -> openser from wr
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3094 3c298f89-4303-0410-b956-a3cf2f4a3e73
2006-01-31 16:51:23 +00:00

72 lines
1.9 KiB
Diff

--- openser-1.0.0-tls.orig/Makefile.defs 2005-10-28 18:32:39.000000000 +0200
+++ openser-1.0.0-tls/Makefile.defs 2006-01-15 23:40:18.391547040 +0100
@@ -917,7 +917,7 @@
endif
YACC_FLAGS=-d -b cfg
# on solaris add -lxnet (e.g. LIBS= -lxnet)
-LIBS= -lfl -ldl -lresolv
+LIBS= -ldl -lresolv
#os specific stuff
@@ -955,7 +955,7 @@
endif
OLD_SOLARIS= $(shell echo "$(OSREL)" | \
sed -e 's/^5\.[0-6][^0-9]*$$/yes/' )
- LIBS+= -L$(LOCALBASE)/lib -lfl -lxnet -lnsl
+ LIBS+= -L$(LOCALBASE)/lib -lxnet -lnsl
ifeq ($(OLD_SOLARIS), yes)
LIBS+=-lposix4
else
@@ -970,9 +970,9 @@
ifneq ($(found_lock_method), yes)
DEFS+= -DUSE_PTHREAD_MUTEX # try pthread sems
found_lock_method=yes
- LIBS= -pthread -lfl #dlopen is in libc
+ LIBS= -pthread #dlopen is in libc
else
- LIBS= -lfl #dlopen is in libc
+ LIBS= #dlopen is in libc
endif
YACC=yacc
endif
@@ -987,7 +987,7 @@
# (symbols on openbsd are prefixed by "_")
YACC=yacc
# no sched_yield on openbsd unless linking with c_r (not recommended)
- LIBS= -lfl
+ LIBS=
OPENBSD_IS_AOUT= $(shell echo "$(OSREL)" | \
sed -e 's/^3\.[0-3][^0-9]*$$/yes/' |sed -e 's/^[0-2]\..*/yes/')
# exception: on sparc openbsd 3.2 is elf and not aout
@@ -1014,7 +1014,7 @@
found_lock_method=yes
endif
YACC=yacc
- LIBS= -lfl
+ LIBS=
endif
# OS X support, same as freebsd
@@ -1028,9 +1028,9 @@
ifneq ($(found_lock_method), yes)
DEFS+= -DUSE_PTHREAD_MUTEX # try pthread sems
found_lock_method=yes
- LIBS= -pthread -lfl -lresolv #dlopen is in libc
+ LIBS= -pthread -lresolv #dlopen is in libc
else
- LIBS= -lfl -lresolv #dlopen is in libc
+ LIBS= -lresolv #dlopen is in libc
endif
LDFLAGS= # darwin doesn't like -O2 or -E
MOD_LDFLAGS= -bundle -bundle_loader ../../$(MAIN_NAME)
@@ -1047,7 +1047,7 @@
#add libssl if needed
ifneq ($(TLS),)
-DEFS+= -I$(LOCALBASE)/ssl/include
+DEFS+= -I$(LOCALBASE)/include
LIBS+= -L$(LOCALBASE)/lib -L$(LOCALBASE)/ssl/lib -lssl -lcrypto
endif