1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-21 00:10:14 +03:00
openwrt-xburst/toolchain/glibc/patches/2.3.6/602-powerpc_cflags_initfini.patch
nico c3c59f4189 [massive] add support for alternative C libraries (currently only glibc/eglibc)
other (related) changes:
 - kernel headers are now installed using "make headers_install" on 2.6
 - target names now contain an openwrt "vendor" tag (e.g. mips-openwrt-linux-gnu)
 - build directory names now contain gcc/libc name/version
 - default cpu for x86 is now i486 (required to build glibc/eglibc)


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13931 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-01-08 01:49:11 +00:00

13 lines
671 B
Diff

diff -ruN glibc-2.3.6-orig/sysdeps/powerpc/powerpc32/Makefile glibc-2.3.6/sysdeps/powerpc/powerpc32/Makefile
--- glibc-2.3.6-orig/sysdeps/powerpc/powerpc32/Makefile 2003-07-12 00:46:12.000000000 +0200
+++ glibc-2.3.6/sysdeps/powerpc/powerpc32/Makefile 2008-11-10 16:02:12.760497684 +0100
@@ -21,7 +21,7 @@
ifneq ($(elf),no)
# The initfini generation code doesn't work in the presence of -fPIC, so
# we use -fpic instead which is much better.
-CFLAGS-initfini.s = -g0 -fpic -O1
+CFLAGS-initfini.s = -fpic -O1 $(fno-unit-at-a-time)
# There is no benefit to using sdata for these objects, and the user
# of the library should be able to control what goes into sdata.