1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-20 22:59:18 +03:00
openwrt-xburst/target/linux/generic/patches-3.0/832-ledtrig_usbdev.patch
hauke ed6be451a0 linux/generic: Add support for 3.0-rc3
Also make linux identify itself properly as 3.0, not 3.0.0.

Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com>


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27191 3c298f89-4303-0410-b956-a3cf2f4a3e73
2011-06-15 21:31:01 +00:00

22 lines
761 B
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -480,4 +480,11 @@ config LEDS_TRIGGER_NETDEV
This allows LEDs to be controlled by network device activity.
If unsure, say Y.
+config LEDS_TRIGGER_USBDEV
+ tristate "LED USB device Trigger"
+ depends on USB && LEDS_TRIGGERS
+ help
+ This allows LEDs to be controlled by the presence/activity of
+ an USB device. If unsure, say N.
+
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -56,3 +56,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o