mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 05:34:03 +02:00
ae2566d99c
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12987 3c298f89-4303-0410-b956-a3cf2f4a3e73
13 lines
365 B
Diff
13 lines
365 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -549,6 +549,9 @@ endif
|
|
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
|
|
|
+# improve gcc optimization
|
|
+CFLAGS += $(call cc-option,-funit-at-a-time,)
|
|
+
|
|
# warn about C99 declaration after statement
|
|
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
|
|
|