mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-11 14:59:41 +02:00
775e69dfac
This patch adds preliminary support for the Mikrotik RB2011L. The NAND flash is not yet supported, so only the initramfs kernel can be used for now. [juhosg: remove unnecessary PCI/USB related stuff, the board does not use that, update commit message] Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33344 3c298f89-4303-0410-b956-a3cf2f4a3e73
51 lines
1.9 KiB
Diff
51 lines
1.9 KiB
Diff
--- a/arch/mips/ath79/Kconfig
|
|
+++ b/arch/mips/ath79/Kconfig
|
|
@@ -333,6 +333,11 @@ config ATH79_MACH_RB750
|
|
select ATH79_DEV_AP9X_PCI if PCI
|
|
select ATH79_DEV_USB
|
|
|
|
+config ATH79_MACH_RB2011
|
|
+ bool "MikroTik RouterBOARD 2011 support"
|
|
+ select SOC_AR934x
|
|
+ select ATH79_DEV_ETH
|
|
+
|
|
config ATH79_MACH_WNDR3700
|
|
bool "NETGEAR WNDR3700 board support"
|
|
select SOC_AR71XX
|
|
--- a/arch/mips/ath79/machtypes.h
|
|
+++ b/arch/mips/ath79/machtypes.h
|
|
@@ -61,6 +61,7 @@ enum ath79_mach_type {
|
|
ATH79_MACH_RB_750G_R3, /* MikroTik RouterBOARD 750GL */
|
|
ATH79_MACH_RB_751, /* MikroTik RouterBOARD 751 */
|
|
ATH79_MACH_RB_751G, /* Mikrotik RouterBOARD 751G */
|
|
+ ATH79_MACH_RB_2011L, /* Mikrotik RouterBOARD 2011L */
|
|
ATH79_MACH_RW2458N, /* Redwave RW2458N */
|
|
ATH79_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
|
|
ATH79_MACH_TEW_673GRU, /* TRENDnet TEW-673GRU */
|
|
Index: linux-3.3.8/arch/mips/ath79/Makefile
|
|
===================================================================
|
|
--- linux-3.3.8.orig/arch/mips/ath79/Makefile
|
|
+++ linux-3.3.8/arch/mips/ath79/Makefile
|
|
@@ -65,6 +65,7 @@ obj-$(CONFIG_ATH79_MACH_PB44) += mach-p
|
|
obj-$(CONFIG_ATH79_MACH_PB92) += mach-pb92.o
|
|
obj-$(CONFIG_ATH79_MACH_RB4XX) += mach-rb4xx.o
|
|
obj-$(CONFIG_ATH79_MACH_RB750) += mach-rb750.o
|
|
+obj-$(CONFIG_ATH79_MACH_RB2011) += mach-rb2011.o
|
|
obj-$(CONFIG_ATH79_MACH_RW2458N) += mach-rw2458n.o
|
|
obj-$(CONFIG_ATH79_MACH_TEW_632BRP) += mach-tew-632brp.o
|
|
obj-$(CONFIG_ATH79_MACH_TEW_673GRU) += mach-tew-673gru.o
|
|
Index: linux-3.3.8/arch/mips/ath79/prom.c
|
|
===================================================================
|
|
--- linux-3.3.8.orig/arch/mips/ath79/prom.c
|
|
+++ linux-3.3.8/arch/mips/ath79/prom.c
|
|
@@ -181,7 +181,8 @@ void __init prom_init(void)
|
|
}
|
|
}
|
|
|
|
- if (strstr(arcs_cmdline, "board=750Gr3"))
|
|
+ if (strstr(arcs_cmdline, "board=750Gr3") ||
|
|
+ strstr(arcs_cmdline, "board=2011L"))
|
|
ath79_prom_append_cmdline("console", "ttyS0,115200");
|
|
}
|
|
|