1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-15 22:11:31 +03:00
openwrt-xburst/target/linux/ar71xx/patches-3.3/616-MIPS-ath79-EW_Dorin-support.patch
nbd 669a7a0710 ar71xx: add support for the embeddedwireless Dorin board (based on patch by embeddedwireless.de)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32447 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-06-19 00:22:04 +00:00

42 lines
1.4 KiB
Diff

--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
@@ -240,6 +240,18 @@
select ATH79_DEV_M25P80
select ATH79_DEV_USB
+config ATH79_MACH_EW_DORIN
+ bool "embedded wireless Dorin Platform support"
+ select SOC_AR933X
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_WMAC
+ select ATH79_DEV_ETH
+ help
+ Say 'Y' here if you want your kernel to support the
+ Dorin Platform from www.80211.de .
+
config ATH79_MACH_JA76PF
bool "jjPlus JA76PF board support"
select SOC_AR71XX
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
@@ -32,6 +32,7 @@
ATH79_MACH_DIR_615_C1, /* D-Link DIR-615 rev. C1 */
ATH79_MACH_DIR_615_E4, /* D-Link DIR-615 rev. E4 */
ATH79_MACH_DIR_825_B1, /* D-Link DIR-825 rev. B1 */
+ ATH79_MACH_EW_DORIN, /* embedded wireless Dorin Platform */
ATH79_MACH_EAP7660D, /* Senao EAP7660D */
ATH79_MACH_JA76PF, /* jjPlus JA76PF */
ATH79_MACH_JA76PF2, /* jjPlus JA76PF2 */
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
@@ -49,6 +49,7 @@
obj-$(CONFIG_ATH79_MACH_DIR_600_A1) += mach-dir-600-a1.o
obj-$(CONFIG_ATH79_MACH_DIR_615_C1) += mach-dir-615-c1.o
obj-$(CONFIG_ATH79_MACH_DIR_825_B1) += mach-dir-825-b1.o
+obj-$(CONFIG_ATH79_MACH_EW_DORIN) += mach-ew-dorin.o
obj-$(CONFIG_ATH79_MACH_EAP7660D) += mach-eap7660d.o
obj-$(CONFIG_ATH79_MACH_JA76PF) += mach-ja76pf.o
obj-$(CONFIG_ATH79_MACH_JWAP003) += mach-jwap003.o