mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 23:42:49 +02:00
8bccd2e819
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9719 3c298f89-4303-0410-b956-a3cf2f4a3e73
179 lines
6.0 KiB
Diff
179 lines
6.0 KiB
Diff
Index: madwifi-dfs-r3053/ath/if_ath.c
|
|
===================================================================
|
|
--- madwifi-dfs-r3053.orig/ath/if_ath.c 2007-12-13 05:25:13.122373270 +0100
|
|
+++ madwifi-dfs-r3053/ath/if_ath.c 2007-12-13 05:25:13.342385808 +0100
|
|
@@ -42,7 +42,7 @@
|
|
* This software is derived from work of Atsushi Onoe; his contribution
|
|
* is greatly appreciated.
|
|
*/
|
|
-#define AR_DEBUG
|
|
+#undef AR_DEBUG
|
|
#include "if_ath_debug.h"
|
|
#include "opt_ah.h"
|
|
|
|
@@ -516,9 +516,11 @@
|
|
u_int8_t csz;
|
|
|
|
sc->devid = devid;
|
|
+#ifdef AR_DEBUG
|
|
ath_debug_global = (ath_debug & ATH_DEBUG_GLOBAL);
|
|
sc->sc_debug = (ath_debug & ~ATH_DEBUG_GLOBAL);
|
|
DPRINTF(sc, ATH_DEBUG_ANY, "%s: devid 0x%x\n", __func__, devid);
|
|
+#endif
|
|
|
|
/*
|
|
* Cache line size is used to size and align various
|
|
@@ -1280,12 +1282,14 @@
|
|
/* If no default VAP debug flags are passed, allow a few to
|
|
* transfer down from the driver to new VAPs so we can have load
|
|
* time debugging for VAPs too. */
|
|
+#ifdef AR_DEBUG
|
|
vap->iv_debug = 0 |
|
|
((sc->sc_debug & ATH_DEBUG_RATE) ? IEEE80211_MSG_XRATE : 0) |
|
|
((sc->sc_debug & ATH_DEBUG_XMIT) ? IEEE80211_MSG_OUTPUT : 0) |
|
|
((sc->sc_debug & ATH_DEBUG_RECV) ? IEEE80211_MSG_INPUT : 0) |
|
|
0
|
|
;
|
|
+#endif
|
|
}
|
|
ic->ic_debug = (sc->sc_default_ieee80211_debug & IEEE80211_MSG_IC);
|
|
|
|
@@ -10308,9 +10312,11 @@
|
|
/* XXX validate? */
|
|
sc->sc_ledpin = val;
|
|
break;
|
|
+#ifdef AR_DEBUG
|
|
case ATH_DEBUG:
|
|
sc->sc_debug = (val & ~ATH_DEBUG_GLOBAL);
|
|
ath_debug_global = (val & ATH_DEBUG_GLOBAL);
|
|
+#endif
|
|
break;
|
|
case ATH_TXANTENNA:
|
|
/*
|
|
@@ -10721,9 +10727,11 @@
|
|
}
|
|
|
|
/* initialize values */
|
|
+#ifdef AR_DEBUG
|
|
ath_debug_global = (ath_debug & ATH_DEBUG_GLOBAL);
|
|
sc->sc_debug = (ath_debug & ~ATH_DEBUG_GLOBAL);
|
|
sc->sc_default_ieee80211_debug = ieee80211_debug;
|
|
+#endif
|
|
sc->sc_txantenna = 0; /* default to auto-selection */
|
|
sc->sc_txintrperiod = ATH_TXQ_INTR_PERIOD;
|
|
}
|
|
Index: madwifi-dfs-r3053/ath_rate/amrr/amrr.c
|
|
===================================================================
|
|
--- madwifi-dfs-r3053.orig/ath_rate/amrr/amrr.c 2007-12-13 05:25:10.422219395 +0100
|
|
+++ madwifi-dfs-r3053/ath_rate/amrr/amrr.c 2007-12-13 05:25:13.342385808 +0100
|
|
@@ -70,7 +70,7 @@
|
|
|
|
#include "amrr.h"
|
|
|
|
-#define AMRR_DEBUG
|
|
+#undef AMRR_DEBUG
|
|
#ifdef AMRR_DEBUG
|
|
#define DPRINTF(sc, _fmt, ...) do { \
|
|
if (sc->sc_debug & 0x10) \
|
|
Index: madwifi-dfs-r3053/ath_rate/minstrel/minstrel.c
|
|
===================================================================
|
|
--- madwifi-dfs-r3053.orig/ath_rate/minstrel/minstrel.c 2007-12-13 05:25:12.006309667 +0100
|
|
+++ madwifi-dfs-r3053/ath_rate/minstrel/minstrel.c 2007-12-13 05:25:13.350386263 +0100
|
|
@@ -117,7 +117,7 @@
|
|
|
|
#include "minstrel.h"
|
|
|
|
-#define MINSTREL_DEBUG
|
|
+#undef MINSTREL_DEBUG
|
|
#ifdef MINSTREL_DEBUG
|
|
enum {
|
|
ATH_DEBUG_RATE = 0x00000010 /* rate control */
|
|
Index: madwifi-dfs-r3053/ath_rate/onoe/onoe.c
|
|
===================================================================
|
|
--- madwifi-dfs-r3053.orig/ath_rate/onoe/onoe.c 2007-12-13 05:25:10.438220308 +0100
|
|
+++ madwifi-dfs-r3053/ath_rate/onoe/onoe.c 2007-12-13 05:25:13.354386489 +0100
|
|
@@ -66,7 +66,7 @@
|
|
|
|
#include "onoe.h"
|
|
|
|
-#define ONOE_DEBUG
|
|
+#undef ONOE_DEBUG
|
|
#ifdef ONOE_DEBUG
|
|
enum {
|
|
ATH_DEBUG_RATE = 0x00000010, /* rate control */
|
|
Index: madwifi-dfs-r3053/ath_rate/sample/sample.c
|
|
===================================================================
|
|
--- madwifi-dfs-r3053.orig/ath_rate/sample/sample.c 2007-12-13 05:25:10.446220763 +0100
|
|
+++ madwifi-dfs-r3053/ath_rate/sample/sample.c 2007-12-13 05:25:13.358386718 +0100
|
|
@@ -68,7 +68,7 @@
|
|
|
|
#include "sample.h"
|
|
|
|
-#define SAMPLE_DEBUG
|
|
+#undef SAMPLE_DEBUG
|
|
#ifdef SAMPLE_DEBUG
|
|
enum {
|
|
ATH_DEBUG_RATE = 0x00000010, /* rate control */
|
|
Index: madwifi-dfs-r3053/tools/do_multi.c
|
|
===================================================================
|
|
--- madwifi-dfs-r3053.orig/tools/do_multi.c 2007-12-13 05:25:11.242266126 +0100
|
|
+++ madwifi-dfs-r3053/tools/do_multi.c 2007-12-13 05:25:13.362386947 +0100
|
|
@@ -9,16 +9,20 @@
|
|
|
|
progname = basename(argv[0]);
|
|
|
|
+#if 0
|
|
if(strcmp(progname, "80211debug") == 0)
|
|
ret = a80211debug_init(argc, argv);
|
|
+#endif
|
|
if(strcmp(progname, "80211stats") == 0)
|
|
ret = a80211stats_init(argc, argv);
|
|
if(strcmp(progname, "athchans") == 0)
|
|
ret = athchans_init(argc, argv);
|
|
if(strcmp(progname, "athctrl") == 0)
|
|
ret = athctrl_init(argc, argv);
|
|
+#if 0
|
|
if(strcmp(progname, "athdebug") == 0)
|
|
ret = athdebug_init(argc, argv);
|
|
+#endif
|
|
if(strcmp(progname, "athkey") == 0)
|
|
ret = athkey_init(argc, argv);
|
|
if(strcmp(progname, "athstats") == 0)
|
|
Index: madwifi-dfs-r3053/tools/Makefile
|
|
===================================================================
|
|
--- madwifi-dfs-r3053.orig/tools/Makefile 2007-12-13 05:25:11.246266355 +0100
|
|
+++ madwifi-dfs-r3053/tools/Makefile 2007-12-13 05:25:13.362386947 +0100
|
|
@@ -48,7 +48,7 @@
|
|
|
|
|
|
ALLPROGS= athstats 80211stats athkey athchans athctrl \
|
|
- athdebug 80211debug wlanconfig ath_info
|
|
+ wlanconfig ath_info
|
|
|
|
OBJS= $(patsubst %,%.o,$(ALLPROGS) do_multi)
|
|
ALL= ${OBJS} madwifi_multi
|
|
@@ -84,7 +84,7 @@
|
|
${CC} -c -o do_multi.o -DDOMULTI=1 ${ALL_CFLAGS} do_multi.c
|
|
madwifi_multi: $(OBJS)
|
|
${CC} -o madwifi_multi ${LDFLAGS} ${OBJS}
|
|
- for i in athstats 80211stats athkey athchans athctrl athdebug wlanconfig 80211debug; do \
|
|
+ for i in athstats 80211stats athkey athchans athctrl wlanconfig; do \
|
|
ln -s -f madwifi_multi $$i; \
|
|
done
|
|
|
|
Index: madwifi-dfs-r3053/net80211/ieee80211_linux.h
|
|
===================================================================
|
|
--- madwifi-dfs-r3053.orig/net80211/ieee80211_linux.h 2007-12-13 05:25:10.470222132 +0100
|
|
+++ madwifi-dfs-r3053/net80211/ieee80211_linux.h 2007-12-13 05:25:13.362386947 +0100
|
|
@@ -29,8 +29,8 @@
|
|
#ifndef _NET80211_IEEE80211_LINUX_H_
|
|
#define _NET80211_IEEE80211_LINUX_H_
|
|
|
|
-#define IEEE80211_DEBUG
|
|
-#define IEEE80211_DEBUG_REFCNT /* Node reference count debugging */
|
|
+#undef IEEE80211_DEBUG
|
|
+#undef IEEE80211_DEBUG_REFCNT /* Node reference count debugging */
|
|
/* #define ATH_DEBUG_SPINLOCKS */ /* announce before spinlocking */
|
|
|
|
#include <linux/wireless.h>
|