1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 13:17:42 +03:00
openwrt-xburst/target/linux/atheros/patches-2.6.28/100-board.patch
hauke 82c4f96e01 [atheros]: Add initial kernel 2.6.28 support for atheros target.
The include files moved from /include/asm-mips/mach-atheros/ to /arch/mips/include/asm/mach-atheros/
This patch is based on the old kernel 2.6.27 patches.


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14584 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-02-20 16:27:42 +00:00

67 lines
1.7 KiB
Diff

--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -60,6 +60,18 @@ config BCM47XX
help
Support for BCM47XX based boards
+config ATHEROS
+ bool "Atheros SoC support (EXPERIMENTAL)"
+ depends on EXPERIMENTAL
+ select DMA_NONCOHERENT
+ select CEVT_R4K
+ select CSRC_R4K
+ select IRQ_CPU
+ select SYS_HAS_CPU_MIPS32_R1
+ select SYS_SUPPORTS_BIG_ENDIAN
+ select SYS_SUPPORTS_32BIT_KERNEL
+ select GENERIC_GPIO
+
config MIPS_COBALT
bool "Cobalt Server"
select CEVT_R4K
@@ -597,6 +609,7 @@ config WR_PPMC
endchoice
+source "arch/mips/atheros/Kconfig"
source "arch/mips/alchemy/Kconfig"
source "arch/mips/basler/excite/Kconfig"
source "arch/mips/emma/Kconfig"
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
@@ -278,6 +278,13 @@ libs-$(CONFIG_MIPS_XXS1500) += arch/mips
load-$(CONFIG_MIPS_XXS1500) += 0xffffffff80100000
#
+# Atheros AR5312/AR2312 WiSoC
+#
+core-$(CONFIG_ATHEROS) += arch/mips/atheros/
+cflags-$(CONFIG_ATHEROS) += -I$(srctree)/arch/mips/include/asm/mach-atheros
+load-$(CONFIG_ATHEROS) += 0xffffffff80041000
+
+#
# Cobalt Server
#
core-$(CONFIG_MIPS_COBALT) += arch/mips/cobalt/
--- a/arch/mips/include/asm/bootinfo.h
+++ b/arch/mips/include/asm/bootinfo.h
@@ -57,6 +57,18 @@
#define MACH_MIKROTIK_RB532 0 /* Mikrotik RouterBoard 532 */
#define MACH_MIKROTIK_RB532A 1 /* Mikrotik RouterBoard 532A */
+/*
+ * Valid machtype for group ATHEROS
+ */
+#define MACH_GROUP_ATHEROS 26
+#define MACH_ATHEROS_AR5312 0
+#define MACH_ATHEROS_AR2312 1
+#define MACH_ATHEROS_AR2313 2
+#define MACH_ATHEROS_AR2315 3
+#define MACH_ATHEROS_AR2316 4
+#define MACH_ATHEROS_AR2317 5
+#define MACH_ATHEROS_AR2318 6
+
#define CL_SIZE COMMAND_LINE_SIZE
extern char *system_type;