1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-20 12:27:07 +03:00
openwrt-xburst/package/fuse24/patches/101-kmod_build.patch
hauke 71013384a4 [fuse24] Some fixes for fuse24.
Because sshfs expects character device to be /dev/fuse instead of /dev/misc/fuse, sshfs fails.
This patch creates fuse device at /dev/fuse instead, also for compatibility the postinstall script (only executed when manually installed per opkg) creates /dev/misc/fuse
added the dcache enabled kernel message to fuse24

Closes #5333


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16447 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-06-14 11:36:19 +00:00

46 lines
1.0 KiB
Diff

--- a/kernel/Makefile.in
+++ b/kernel/Makefile.in
@@ -54,23 +54,8 @@ distdir: $(DISTFILES) $(COMPATDISTFILES)
ifeq ($(majver), 2.4)
-CC = gcc
-LD = ld
-CFLAGS = -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -pipe @KERNELCFLAGS@
-CPPFLAGS = -I@kernelsrc@/include -I. -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -DFUSE_VERSION=\"$(VERSION)\" @KERNELCPPFLAGS@
-
fuse_objs = dev.o dir.o file.o inode.o compat/parser.o
-SUFFIXES = .c .o .s
-
-all-spec: fuse.o
-
-.c.o:
- $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
-
-fuse.o: $(fuse_objs)
- $(LD) -r -o fuse.o $(fuse_objs)
-
fuse_headers = fuse_i.h fuse_kernel.h
dev.o: $(fuse_headers)
@@ -78,6 +63,18 @@ dir.o: $(fuse_headers)
file.o: $(fuse_headers)
inode.o: $(fuse_headers)
+EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"
+
+O_TARGET := fuse.o
+
+obj-y := $(fuse_objs)
+obj-m := $(O_TARGET)
+
+-include $(TOPDIR)/Rules.make
+
+all-spec:
+ $(MAKE) -C @kernelsrc@ TOPDIR=@kernelsrc@ SUBDIRS=$(PWD) modules
+
else
EXTRA_CFLAGS += -DFUSE_VERSION=\"$(VERSION)\"