mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 09:34:04 +02:00
5e3ba36eb5
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18505 3c298f89-4303-0410-b956-a3cf2f4a3e73
82 lines
2.1 KiB
Diff
82 lines
2.1 KiB
Diff
--- a/drivers/net/wireless/ath/ath9k/Makefile
|
|
+++ b/drivers/net/wireless/ath/ath9k/Makefile
|
|
@@ -7,7 +7,7 @@ ath9k-y += beacon.o \
|
|
|
|
ath9k-$(CONFIG_PCI) += pci.o
|
|
ath9k-$(CONFIG_ATHEROS_AR71XX) += ahb.o
|
|
-ath9k-$(CONFIG_ATH9K_DEBUG) += debug.o
|
|
+ath9k-$(CONFIG_ATH9K_DEBUGFS) += debug.o
|
|
|
|
obj-$(CONFIG_ATH9K) += ath9k.o
|
|
|
|
--- a/drivers/net/wireless/ath/ath9k/ath9k.h
|
|
+++ b/drivers/net/wireless/ath/ath9k/ath9k.h
|
|
@@ -483,7 +483,7 @@ struct ath_softc {
|
|
|
|
int beacon_interval;
|
|
|
|
-#ifdef CONFIG_ATH9K_DEBUG
|
|
+#ifdef CONFIG_ATH9K_DEBUGFS
|
|
struct ath9k_debug debug;
|
|
#endif
|
|
struct ath_beacon_config cur_beacon_conf;
|
|
--- a/drivers/net/wireless/ath/ath9k/debug.c
|
|
+++ b/drivers/net/wireless/ath/ath9k/debug.c
|
|
@@ -31,6 +31,8 @@ static int ath9k_debugfs_open(struct ino
|
|
return 0;
|
|
}
|
|
|
|
+#ifdef CONFIG_ATH_DEBUG
|
|
+
|
|
static ssize_t read_file_debug(struct file *file, char __user *user_buf,
|
|
size_t count, loff_t *ppos)
|
|
{
|
|
@@ -71,6 +73,8 @@ static const struct file_operations fops
|
|
.owner = THIS_MODULE
|
|
};
|
|
|
|
+#endif
|
|
+
|
|
static ssize_t read_file_dma(struct file *file, char __user *user_buf,
|
|
size_t count, loff_t *ppos)
|
|
{
|
|
@@ -563,10 +567,12 @@ int ath9k_init_debug(struct ath_hw *ah)
|
|
if (!sc->debug.debugfs_phy)
|
|
goto err;
|
|
|
|
+#ifdef CONFIG_ATH_DEBUG
|
|
sc->debug.debugfs_debug = debugfs_create_file("debug",
|
|
S_IRUSR | S_IWUSR, sc->debug.debugfs_phy, sc, &fops_debug);
|
|
if (!sc->debug.debugfs_debug)
|
|
goto err;
|
|
+#endif
|
|
|
|
sc->debug.debugfs_dma = debugfs_create_file("dma", S_IRUSR,
|
|
sc->debug.debugfs_phy, sc, &fops_dma);
|
|
--- a/drivers/net/wireless/ath/ath9k/debug.h
|
|
+++ b/drivers/net/wireless/ath/ath9k/debug.h
|
|
@@ -23,13 +23,13 @@
|
|
struct ath_txq;
|
|
struct ath_buf;
|
|
|
|
-#ifdef CONFIG_ATH9K_DEBUG
|
|
+#ifdef CONFIG_ATH9K_DEBUGFS
|
|
#define TX_STAT_INC(q, c) sc->debug.stats.txstats[q].c++
|
|
#else
|
|
#define TX_STAT_INC(q, c) do { } while (0)
|
|
#endif
|
|
|
|
-#ifdef CONFIG_ATH9K_DEBUG
|
|
+#ifdef CONFIG_ATH9K_DEBUGFS
|
|
|
|
/**
|
|
* struct ath_interrupt_stats - Contains statistics about interrupts
|
|
@@ -186,6 +186,6 @@ static inline void ath_debug_stat_retrie
|
|
{
|
|
}
|
|
|
|
-#endif /* CONFIG_ATH9K_DEBUG */
|
|
+#endif /* CONFIG_ATH9K_DEBUGFS */
|
|
|
|
#endif /* DEBUG_H */
|