1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 16:19:53 +03:00
openwrt-xburst/target/linux/generic-2.6/patches/004-extra_optimization.patch
nbd a3df50fd61 refresh kernel patches so that they apply cleanly
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7347 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-05-26 19:41:42 +00:00

14 lines
524 B
Diff

diff -urN linux-2.6.21.1.old/Makefile linux-2.6.21.1.dev/Makefile
--- linux-2.6.21.1.old/Makefile 2007-04-27 23:49:26.000000000 +0200
+++ linux-2.6.21.1.dev/Makefile 2007-05-26 19:14:22.967804016 +0200
@@ -507,6 +507,9 @@
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)