mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 21:38:26 +02:00
4dbb6eef31
Also remove static mtd partition definitions. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29412 3c298f89-4303-0410-b956-a3cf2f4a3e73
26 lines
861 B
Diff
26 lines
861 B
Diff
--- a/drivers/mtd/Kconfig
|
|
+++ b/drivers/mtd/Kconfig
|
|
@@ -176,6 +176,12 @@ config MTD_AR7_PARTS
|
|
|
|
endif # MTD_PARTITIONS
|
|
|
|
+config MTD_WRT160NL_PARTS
|
|
+ tristate "Linksys WRT160NL partitioning support"
|
|
+ depends on MTD_PARTITIONS && AR71XX_MACH_WRT160NL
|
|
+ ---help---
|
|
+ Linksys WRT160NL partitioning support
|
|
+
|
|
config MTD_MYLOADER_PARTS
|
|
tristate "MyLoader partition parsing"
|
|
depends on MTD_PARTITIONS && (ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX)
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redbo
|
|
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|
|
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
|
|
+obj-$(CONFIG_MTD_WRT160NL_PARTS) += wrt160nl_part.o
|
|
obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
|
|
|
|
# 'Users' - code which presents functionality to userspace.
|