1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 01:44:10 +03:00
openwrt-xburst/target/linux/adm5120-2.6/patches/002-adm5120_flash.patch
juhosg 8cb689db3a [adm5120] restore right patches for 2.6.21.5
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7800 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-06-30 15:23:06 +00:00

28 lines
1.0 KiB
Diff

Index: linux-2.6.21.1/drivers/mtd/maps/Kconfig
===================================================================
--- linux-2.6.21.1.orig/drivers/mtd/maps/Kconfig
+++ linux-2.6.21.1/drivers/mtd/maps/Kconfig
@@ -605,5 +605,10 @@ config MTD_PLATRAM
This selection automatically selects the map_ram driver.
+config MTD_ADM5120
+ tristate "Map driver for ADMtek ADM5120 boards"
+ depends on MIPS_ADM5120
+ select MTD_CFI_AMDSTD
+
endmenu
Index: linux-2.6.21.1/drivers/mtd/maps/Makefile
===================================================================
--- linux-2.6.21.1.orig/drivers/mtd/maps/Makefile
+++ linux-2.6.21.1/drivers/mtd/maps/Makefile
@@ -45,6 +45,7 @@ obj-$(CONFIG_MTD_OCELOT) += ocelot.o
obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
obj-$(CONFIG_MTD_PCI) += pci.o
obj-$(CONFIG_MTD_ALCHEMY) += alchemy-flash.o
+obj-$(CONFIG_MTD_ADM5120) += adm5120_mtd.o
obj-$(CONFIG_MTD_LASAT) += lasat.o
obj-$(CONFIG_MTD_AUTCPU12) += autcpu12-nvram.o
obj-$(CONFIG_MTD_EDB7312) += edb7312.o