1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 01:44:10 +03:00
openwrt-xburst/target/linux/adm5120-2.6/patches/006-adm5120_leds.patch
juhosg 8cb689db3a [adm5120] restore right patches for 2.6.21.5
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7800 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-06-30 15:23:06 +00:00

46 lines
1.5 KiB
Diff

Index: linux-2.6.21.1/drivers/leds/Kconfig
===================================================================
--- linux-2.6.21.1.orig/drivers/leds/Kconfig
+++ linux-2.6.21.1/drivers/leds/Kconfig
@@ -19,6 +19,27 @@ config LEDS_CLASS
comment "LED drivers"
+config LEDS_GPIO
+ tristate "LED support for LEDS on GPIO lines"
+ depends on LEDS_CLASS && GENERIC_GPIO
+ help
+ This option enables support for LEDs connected to GPIO lines
+
+config LEDS_ADM5120
+ tristate "LED Support for ADM5120 GPIO LEDs"
+ depends on LEDS_GPIO && MIPS_ADM5120
+ help
+ This option enables support for LEDs connected to GPIO lines
+ on ADM5120 SoC based platforms.
+
+config LEDS_ADM5120_EXPERIMENTAL
+ bool "Enable ADM5120 LEDs experimental code"
+ depends on LEDS_ADM5120
+
+config LEDS_ADM5120_DIAG
+ bool "Enable ADM5120 LEDs diagnostic mode"
+ depends on LEDS_ADM5120
+
config LEDS_CORGI
tristate "LED Support for the Sharp SL-C7x0 series"
depends on LEDS_CLASS && PXA_SHARP_C7xx
Index: linux-2.6.21.1/drivers/leds/Makefile
===================================================================
--- linux-2.6.21.1.orig/drivers/leds/Makefile
+++ linux-2.6.21.1/drivers/leds/Makefile
@@ -5,6 +5,8 @@ obj-$(CONFIG_LEDS_CLASS) += led-class.o
obj-$(CONFIG_LEDS_TRIGGERS) += led-triggers.o
# LED Platform Drivers
+obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o
+obj-$(CONFIG_LEDS_ADM5120) += leds-adm5120.o
obj-$(CONFIG_LEDS_CORGI) += leds-corgi.o
obj-$(CONFIG_LEDS_LOCOMO) += leds-locomo.o
obj-$(CONFIG_LEDS_SPITZ) += leds-spitz.o