1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-19 10:41:29 +03:00
openwrt-xburst/package/mac80211/patches/403-ath9k-fix-invalid-mac-address-handling.patch
nbd 23674ee048 upgrade mac80211 to 2008-08-20 and clean up some unnecessary patching to config.mk, which frequently causes rejects on new versions
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17326 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-08-20 14:59:55 +00:00

24 lines
666 B
Diff

--- a/drivers/net/wireless/ath/ath9k/hw.c
+++ b/drivers/net/wireless/ath/ath9k/hw.c
@@ -524,8 +524,18 @@ static int ath9k_hw_init_macaddr(struct
ah->macaddr[2 * i] = eeval >> 8;
ah->macaddr[2 * i + 1] = eeval & 0xff;
}
- if (sum == 0 || sum == 0xffff * 3)
- return -EADDRNOTAVAIL;
+ if (!is_valid_ether_addr(ah->macaddr)) {
+ DECLARE_MAC_BUF(macbuf);
+
+ DPRINTF(ah->ah_sc, ATH_DBG_EEPROM,
+ "eeprom contains invalid mac address: %s\n",
+ print_mac(macbuf, ah->macaddr));
+
+ random_ether_addr(ah->macaddr);
+ DPRINTF(ah->ah_sc, ATH_DBG_EEPROM,
+ "random mac address will be used: %s\n",
+ print_mac(macbuf, ah->macaddr));
+ }
return 0;
}