1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-11-04 20:04:04 +02:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.25/004-extra_optimization.patch
juhosg 60289aade7 [kernel] update to 2.6.25.1 and refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11006 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-02 10:17:03 +00:00

15 lines
495 B
Diff

Index: linux-2.6.25.1/Makefile
===================================================================
--- linux-2.6.25.1.orig/Makefile
+++ linux-2.6.25.1/Makefile
@@ -533,6 +533,9 @@ endif
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)