1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-18 19:10:15 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.33/970-ocf_kbuild_integration.patch
matteo 277b4f4f30 kernel: add 2.6.33 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19905 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-02-28 15:20:00 +00:00

26 lines
540 B
Diff

--- a/crypto/Kconfig
+++ b/crypto/Kconfig
@@ -823,6 +823,8 @@ config CRYPTO_ANSI_CPRNG
ANSI X9.31 A.2.4. Not this option must be enabled if CRYPTO_FIPS
is selected
+source "crypto/ocf/Kconfig"
+
source "drivers/crypto/Kconfig"
endif # if CRYPTO
--- a/crypto/Makefile
+++ b/crypto/Makefile
@@ -86,6 +86,11 @@ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
obj-$(CONFIG_CRYPTO_GHASH) += ghash-generic.o
#
+# OCF
+#
+obj-$(CONFIG_OCF_OCF) += ocf/
+
+#
# generic algorithms and the async_tx api
#
obj-$(CONFIG_XOR_BLOCKS) += xor.o