1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-16 19:45:41 +03:00
openwrt-xburst/package/uboot-ifxmips/patches/110-compile_fix.patch
nbd 0b7968af02 uboot-ifxmips: fix compile errors with the cs toolchain due to non-PIC code
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18321 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-11-05 21:25:31 +00:00

26 lines
659 B
Diff

--- a/cpu/mips/Makefile
+++ b/cpu/mips/Makefile
@@ -36,6 +36,9 @@ START := $(addprefix $(obj),$(START))
all: $(obj).depend $(START) $(LIB)
+start.o: start.S
+ $(CC) $(AFLAGS) -fPIC -c -o $@ $<
+
$(LIB): $(OBJS)
$(AR) $(ARFLAGS) $@ $(OBJS)
--- a/Makefile
+++ b/Makefile
@@ -185,8 +185,8 @@ include $(TOPDIR)/config.mk
OBJS = cpu/$(CPU)/start.o
OBJS_BOOTSTRAP = cpu/$(CPU)/start_bootstrap.o
-cpu/$(CPU)/start_bootstrap.S: cpu/$(CPU)/start.S
- ln -s start.S cpu/$(CPU)/start_bootstrap.S
+cpu/$(CPU)/start_bootstrap.o: cpu/$(CPU)/start.S
+ $(CC) $(AFLAGS) -fPIC -DCFG_BOOTSTRAP_CODE -c -o $@ $<
ifeq ($(CPU),i386)
OBJS += cpu/$(CPU)/start16.o