1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 07:46:27 +03:00
openwrt-xburst/target/linux/mcs814x/patches-3.3/001-platform.patch
florian 3a5b7c7629 [mcs814x] do not use MULTI_IRQ_HANDLER it is bogus on our platform
This caused stalls in the Ethernet DMA block, so until properly
written and sorted out, fallback to the assembly version instead.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32470 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-06-20 21:57:45 +00:00

43 lines
1.1 KiB
Diff

--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
@@ -869,6 +869,20 @@ config ARCH_EXYNOS
help
Support for SAMSUNG's EXYNOS SoCs (EXYNOS4/5)
+config ARCH_MCS814X
+ bool "Moschip MCS814x"
+ select CPU_ARM926T
+ select PCI
+ select FIQ
+ select GENERIC_IRQ_CHIP
+ select GENERIC_GPIO
+ select ARCH_REQUIRE_GPIOLIB
+ select CLKDEV_LOOKUP
+ select ARCH_USES_GETTIMEOFFSET
+ select NEED_MACH_MEMORY_H
+ help
+ Support for Moschip MCS814x SoCs (MCS8140).
+
config ARCH_SHARK
bool "Shark"
select CPU_SA110
@@ -1065,6 +1080,8 @@ source "arch/arm/plat-samsung/Kconfig"
source "arch/arm/plat-s3c24xx/Kconfig"
source "arch/arm/plat-s5p/Kconfig"
+source "arch/arm/mach-mcs814x/Kconfig"
+
source "arch/arm/plat-spear/Kconfig"
if ARCH_S3C2410
--- a/arch/arm/Makefile
+++ b/arch/arm/Makefile
@@ -179,6 +179,7 @@ machine-$(CONFIG_ARCH_S3C64XX) := s3c64
machine-$(CONFIG_ARCH_S5P64X0) := s5p64x0
machine-$(CONFIG_ARCH_S5PC100) := s5pc100
machine-$(CONFIG_ARCH_S5PV210) := s5pv210
+machine-$(CONFIG_ARCH_MCS814X) := mcs814x
machine-$(CONFIG_ARCH_EXYNOS4) := exynos
machine-$(CONFIG_ARCH_SA1100) := sa1100
machine-$(CONFIG_ARCH_SHARK) := shark