1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 00:48:04 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.36/103-mtd_trxsplit.patch
acoul e4b2118622 linux/adm5120: add preliminary 2.6.36 kernel support (refresh patches)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23224 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-10-04 17:45:05 +00:00

25 lines
717 B
Diff

--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
@@ -63,6 +63,11 @@ config MTD_ROOTFS_SPLIT
depends on MTD_PARTITIONS
default y
+config MTD_TRXSPLIT
+ bool "Automatically find and split TRX partitions"
+ depends on MTD_PARTITIONS
+ default n
+
config MTD_REDBOOT_PARTS
tristate "RedBoot partition table parsing"
depends on MTD_PARTITIONS
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o
mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
+obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o