1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 02:27:44 +03:00
openwrt-xburst/target/linux/ifxmips/patches/100-board.patch
blogic 0a2b2965cd [ifxmips]:
* bump kernel to 2.6.35.8
* merge arcadyn mach files
* fixes ar9
* adds hack for tapi drivers



git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23836 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-11-03 19:02:27 +00:00

63 lines
2.2 KiB
Diff

Index: linux-2.6.35.4/arch/mips/Kconfig
===================================================================
--- linux-2.6.35.4.orig/arch/mips/Kconfig 2010-09-23 20:41:50.000000000 +0200
+++ linux-2.6.35.4/arch/mips/Kconfig 2010-09-23 20:41:52.000000000 +0200
@@ -139,6 +139,9 @@
otherwise choose R3000.
+config IFXMIPS
+ bool "Infineon MIPS"
+
config MACH_JAZZ
bool "Jazz family of machines"
select ARC
@@ -695,6 +698,7 @@
source "arch/mips/vr41xx/Kconfig"
source "arch/mips/cavium-octeon/Kconfig"
source "arch/mips/loongson/Kconfig"
+source "arch/mips/ifxmips/Kconfig"
endmenu
Index: linux-2.6.35.4/arch/mips/Makefile
===================================================================
--- linux-2.6.35.4.orig/arch/mips/Makefile 2010-09-23 20:41:50.000000000 +0200
+++ linux-2.6.35.4/arch/mips/Makefile 2010-09-23 22:41:58.000000000 +0200
@@ -339,6 +339,22 @@
load-$(CONFIG_MIPS_COBALT) += 0xffffffff80080000
#
+# Infineon IFXMIPS
+#
+core-$(CONFIG_IFXMIPS) += arch/mips/ifxmips/common/
+cflags-$(CONFIG_IFXMIPS) += -I$(srctree)/arch/mips/include/asm/mach-ifxmips
+
+core-$(CONFIG_IFXMIPS_DANUBE) += arch/mips/ifxmips/danube/
+cflags-$(CONFIG_IFXMIPS_DANUBE) += -I$(srctree)/arch/mips/include/asm/mach-ifxmips/danube/
+load-$(CONFIG_IFXMIPS_DANUBE) += 0xffffffff80002000
+
+core-$(CONFIG_IFXMIPS_AR9) += arch/mips/ifxmips/ar9/
+cflags-$(CONFIG_IFXMIPS_AR9) += -I$(srctree)/arch/mips/include/asm/mach-ifxmips/ar9/
+load-$(CONFIG_IFXMIPS_AR9) += 0xffffffff80002000
+
+core-$(CONFIG_IFXMIPS_COMPAT) += arch/mips/ifxmips/compat/
+
+#
# DECstation family
#
core-$(CONFIG_MACH_DECSTATION) += arch/mips/dec/
Index: linux-2.6.35.4/arch/mips/pci/Makefile
===================================================================
--- linux-2.6.35.4.orig/arch/mips/pci/Makefile 2010-08-27 01:47:12.000000000 +0200
+++ linux-2.6.35.4/arch/mips/pci/Makefile 2010-09-23 20:41:52.000000000 +0200
@@ -55,7 +55,7 @@
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
obj-$(CONFIG_MIKROTIK_RB532) += pci-rc32434.o ops-rc32434.o fixup-rc32434.o
obj-$(CONFIG_CPU_CAVIUM_OCTEON) += pci-octeon.o pcie-octeon.o
-
+obj-$(CONFIG_IFXMIPS) += pci-ifxmips.o ops-ifxmips.o
ifdef CONFIG_PCI_MSI
obj-$(CONFIG_CPU_CAVIUM_OCTEON) += msi-octeon.o
endif