1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 07:54:38 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.24/010-disable_old_squashfs_compatibility.patch
juhosg 3d542aac84 [kernel] refresh generic 2.6.24 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11188 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-18 20:25:45 +00:00

24 lines
803 B
Diff

Index: linux-2.6.24.7/fs/squashfs/Makefile
===================================================================
--- linux-2.6.24.7.orig/fs/squashfs/Makefile
+++ linux-2.6.24.7/fs/squashfs/Makefile
@@ -4,4 +4,3 @@
obj-$(CONFIG_SQUASHFS) += squashfs.o
squashfs-y += inode.o
-squashfs-y += squashfs2_0.o
Index: linux-2.6.24.7/fs/squashfs/squashfs.h
===================================================================
--- linux-2.6.24.7.orig/fs/squashfs/squashfs.h
+++ linux-2.6.24.7/fs/squashfs/squashfs.h
@@ -24,6 +24,9 @@
#ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#endif
+#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#endif
#ifdef SQUASHFS_TRACE
#define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)