1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 06:46:46 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.24/921-gpio_spi_driver.patch
juhosg 3e6a0c14b4 [package] move spi_gpio driver into the kernel, clean-up SPI modules
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10844 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-04-15 07:33:43 +00:00

29 lines
1.2 KiB
Diff

Index: linux-2.6.23.16/drivers/spi/Kconfig
===================================================================
--- linux-2.6.23.16.orig/drivers/spi/Kconfig
+++ linux-2.6.23.16/drivers/spi/Kconfig
@@ -100,6 +100,11 @@ config SPI_BUTTERFLY
inexpensive battery powered microcontroller evaluation board.
This same cable can be used to flash new firmware.
+config SPI_GPIO
+ tristate "GPIO API based bitbanging SPI controller"
+ depends on SPI_MASTER && GENERIC_GPIO && EXPERIMENTAL
+ select SPI_BITBANG
+
config SPI_IMX
tristate "Freescale iMX SPI controller"
depends on SPI_MASTER && ARCH_IMX && EXPERIMENTAL
Index: linux-2.6.23.16/drivers/spi/Makefile
===================================================================
--- linux-2.6.23.16.orig/drivers/spi/Makefile
+++ linux-2.6.23.16/drivers/spi/Makefile
@@ -16,6 +16,7 @@ obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.
obj-$(CONFIG_SPI_BITBANG) += spi_bitbang.o
obj-$(CONFIG_SPI_AU1550) += au1550_spi.o
obj-$(CONFIG_SPI_BUTTERFLY) += spi_butterfly.o
+obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
obj-$(CONFIG_SPI_IMX) += spi_imx.o
obj-$(CONFIG_SPI_LM70_LLP) += spi_lm70llp.o
obj-$(CONFIG_SPI_PXA2XX) += pxa2xx_spi.o