1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-16 00:25:21 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.34/009-adm5120_leds_switch_trigger.patch
hauke fb3616ed90 adm5120: make patches apply again and refresh them
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24800 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-12-22 17:19:36 +00:00

23 lines
832 B
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -372,4 +372,12 @@ config LEDS_TRIGGER_USBDEV
This allows LEDs to be controlled by the presence/activity of
an USB device. If unsure, say N.
+config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger"
+ depends on LEDS_TRIGGERS && ADM5120
+ help
+ This allows LEDs to be controlled by the port states of
+ the ADM5120 built-in Ethernet Switch
+ If unsure, say N.
+
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -49,3 +49,4 @@ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) +=
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o