1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-16 00:02:13 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.34/310-adm5120_wdt.patch
acoul b94d47a36d [adm5120] refresh kernel patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21218 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-04-28 09:28:13 +00:00

32 lines
1.0 KiB
Diff

--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
@@ -807,6 +807,18 @@ config RC32434_WDT
To compile this driver as a module, choose M here: the
module will be called rc32434_wdt.
+config ADM5120_WDT
+ tristate "Infineon ADM5120 SoC hardware watchdog"
+ depends on WATCHDOG && ADM5120
+ help
+ This is a driver for hardware watchdog integrated in Infineon
+ ADM5120 SoC. This watchdog simply watches your kernel to make sure
+ it doesn't freeze, and if it does, it reboots your computer after a
+ certain amount of time.
+
+ To compile this driver as a module, choose M here: the module will be
+ called adm5120_wdt.
+
config INDYDOG
tristate "Indy/I2 Hardware Watchdog"
depends on SGI_HAS_INDYDOG
--- a/drivers/watchdog/Makefile
+++ b/drivers/watchdog/Makefile
@@ -113,6 +113,7 @@ obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
+obj-$(CONFIG_ADM5120_WDT) += adm5120_wdt.o
# PARISC Architecture