mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 00:24:40 +02:00
da1bd2aad6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27310 3c298f89-4303-0410-b956-a3cf2f4a3e73
27 lines
829 B
Diff
27 lines
829 B
Diff
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -479,6 +479,13 @@ config SPI_TLE62X0
|
|
sysfs interface, with each line presented as a kind of GPIO
|
|
exposing both switch control and diagnostic feedback.
|
|
|
|
+config SPI_RB4XX_CPLD
|
|
+ tristate "MikroTik RB4XX CPLD driver"
|
|
+ depends on AR71XX_MACH_RB4XX
|
|
+ help
|
|
+ SPI driver for the Xilinx CPLD chip present on the
|
|
+ MikroTik RB4xx boards.
|
|
+
|
|
#
|
|
# Add new SPI protocol masters in alphabetical order above this line
|
|
#
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -65,6 +65,7 @@ spi_s3c24xx_hw-$(CONFIG_SPI_S3C24XX_FIQ)
|
|
# ... add above this line ...
|
|
|
|
# SPI protocol drivers (device/link on bus)
|
|
+obj-$(CONFIG_SPI_RB4XX_CPLD) += spi_rb4xx_cpld.o
|
|
obj-$(CONFIG_SPI_SPIDEV) += spidev.o
|
|
obj-$(CONFIG_SPI_TLE62X0) += tle62x0.o
|
|
# ... add above this line ...
|