mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 00:29:41 +02:00
da1bd2aad6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27310 3c298f89-4303-0410-b956-a3cf2f4a3e73
28 lines
896 B
Diff
28 lines
896 B
Diff
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -82,6 +82,14 @@ config SPI_AR71XX
|
|
help
|
|
This is the SPI contoller driver for Atheros AR71xx.
|
|
|
|
+config SPI_PB44
|
|
+ tristate "Atheros PB44 board specific SPI controller"
|
|
+ depends on SPI_MASTER && AR71XX_MACH_PB44
|
|
+ select SPI_BITBANG
|
|
+ help
|
|
+ This is a specific SPI controller driver for the Atheros PB44
|
|
+ reference board.
|
|
+
|
|
config SPI_ATMEL
|
|
tristate "Atmel SPI Controller"
|
|
depends on (ARCH_AT91 || AVR32)
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -29,6 +29,7 @@ obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
|
|
obj-$(CONFIG_SPI_GPIO_OLD) += spi_gpio_old.o
|
|
obj-$(CONFIG_SPI_IMX) += spi_imx.o
|
|
obj-$(CONFIG_SPI_LM70_LLP) += spi_lm70llp.o
|
|
+obj-$(CONFIG_SPI_PB44) += pb44_spi.o
|
|
obj-$(CONFIG_SPI_PXA2XX) += pxa2xx_spi.o
|
|
obj-$(CONFIG_SPI_PXA2XX_PCI) += pxa2xx_spi_pci.o
|
|
obj-$(CONFIG_SPI_OC_TINY) += spi_oc_tiny.o
|