mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 17:22:49 +02:00
d63beb8f0c
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10427 3c298f89-4303-0410-b956-a3cf2f4a3e73
29 lines
988 B
Diff
29 lines
988 B
Diff
Index: linux-2.6.24/drivers/mtd/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.24.orig/drivers/mtd/Kconfig
|
|
+++ linux-2.6.24/drivers/mtd/Kconfig
|
|
@@ -57,6 +57,11 @@ config MTD_ROOTFS_SPLIT
|
|
depends on MTD_PARTITIONS
|
|
default y
|
|
|
|
+config MTD_TRXSPLIT
|
|
+ bool "Automatically find and split TRX partitions"
|
|
+ depends on MTD_PARTITIONS
|
|
+ default n
|
|
+
|
|
config MTD_REDBOOT_PARTS
|
|
tristate "RedBoot partition table parsing"
|
|
depends on MTD_PARTITIONS
|
|
Index: linux-2.6.24/drivers/mtd/Makefile
|
|
===================================================================
|
|
--- linux-2.6.24.orig/drivers/mtd/Makefile
|
|
+++ linux-2.6.24/drivers/mtd/Makefile
|
|
@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o
|
|
mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
|
|
|
|
obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
|
|
+obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
|
|
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
|
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|
|
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|