mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 21:52:28 +02:00
02fb20885e
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31615 3c298f89-4303-0410-b956-a3cf2f4a3e73
23 lines
782 B
Diff
23 lines
782 B
Diff
--- a/drivers/mtd/maps/physmap.c
|
|
+++ b/drivers/mtd/maps/physmap.c
|
|
@@ -78,7 +78,7 @@ static const char *rom_probe_types[] = {
|
|
"map_rom",
|
|
NULL };
|
|
static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", "afs",
|
|
- NULL };
|
|
+ "ar7part", NULL };
|
|
|
|
static int physmap_flash_probe(struct platform_device *dev)
|
|
{
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -10,7 +10,7 @@ obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
|
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
|
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|
|
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
-obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
|
|
+obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o titanpart.o
|
|
obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
|
|
obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
|
|
|