mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-05 15:03:08 +02:00
a50e0e7076
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34247 3c298f89-4303-0410-b956-a3cf2f4a3e73
29 lines
877 B
Diff
29 lines
877 B
Diff
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -559,4 +559,8 @@ config LEDS_TRIGGER_TRANSIENT
|
|
GPIO/PWM based hardware.
|
|
If unsure, say Y.
|
|
|
|
+config LEDS_TRIGGER_MORSE
|
|
+ tristate "LED Morse Trigger"
|
|
+ depends on LEDS_TRIGGERS
|
|
+
|
|
endif # NEW_LEDS
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -65,3 +65,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
|
|
obj-$(CONFIG_LEDS_TRIGGER_CPU) += ledtrig-cpu.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_TRANSIENT) += ledtrig-transient.o
|
|
+obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
|
|
--- a/drivers/leds/ledtrig-morse.c
|
|
+++ b/drivers/leds/ledtrig-morse.c
|
|
@@ -26,7 +26,6 @@
|
|
#include <linux/list.h>
|
|
#include <linux/spinlock.h>
|
|
#include <linux/device.h>
|
|
-#include <linux/sysdev.h>
|
|
#include <linux/timer.h>
|
|
#include <linux/ctype.h>
|
|
#include <linux/leds.h>
|