mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-09 23:53:10 +02:00
4a72ea39d6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18199 3c298f89-4303-0410-b956-a3cf2f4a3e73
38 lines
1.1 KiB
Diff
38 lines
1.1 KiB
Diff
diff -Nru linux-2.6.31.5/arch/mips/kernel/Makefile linux-2.6.31.5.new/arch/mips/kernel/Makefile
|
|
--- linux-2.6.31.5/arch/mips/kernel/Makefile 2009-10-25 12:35:46.137368384 +0200
|
|
+++ linux-2.6.31.5.new/arch/mips/kernel/Makefile 2009-10-25 15:24:04.713493469 +0200
|
|
@@ -2,6 +2,8 @@
|
|
# Makefile for the Linux/MIPS kernel.
|
|
#
|
|
|
|
+CPPFLAGS_vmlinux.lds := $(KBUILD_CFLAGS) $(EXTRA_LDSFLAGS)
|
|
+
|
|
extra-y := head.o init_task.o vmlinux.lds
|
|
|
|
obj-y += cpu-probe.o branch.o entry.o genex.o irq.o process.o \
|
|
diff -Nru linux-2.6.31.5/arch/mips/kernel/vmlinux.lds.S linux-2.6.31.5.new/arch/mips/kernel/vmlinux.lds.S
|
|
--- linux-2.6.31.5/arch/mips/kernel/vmlinux.lds.S 2009-10-23 01:57:56.000000000 +0300
|
|
+++ linux-2.6.31.5.new/arch/mips/kernel/vmlinux.lds.S 2009-10-25 15:26:11.631618513 +0200
|
|
@@ -10,15 +10,15 @@
|
|
note PT_NOTE FLAGS(4); /* R__ */
|
|
}
|
|
|
|
-ifdef CONFIG_32BIT
|
|
- ifdef CONFIG_CPU_LITTLE_ENDIAN
|
|
+#ifdef CONFIG_32BIT
|
|
+ #ifdef CONFIG_CPU_LITTLE_ENDIAN
|
|
jiffies = jiffies_64;
|
|
- else
|
|
+ #else
|
|
jiffies = jiffies_64 + 4;
|
|
- endif
|
|
-else
|
|
+ #endif
|
|
+#else
|
|
jiffies = jiffies_64;
|
|
-endif
|
|
+#endif
|
|
|
|
SECTIONS
|
|
{
|