mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-06 06:06:16 +02:00
dab3ca1324
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2877 3c298f89-4303-0410-b956-a3cf2f4a3e73
402 lines
11 KiB
Diff
402 lines
11 KiB
Diff
diff -Nur linux-2.4.32/drivers/mtd/maps/bcm947xx-flash.c linux-2.4.32-flash/drivers/mtd/maps/bcm947xx-flash.c
|
|
--- linux-2.4.32/drivers/mtd/maps/bcm947xx-flash.c 1970-01-01 01:00:00.000000000 +0100
|
|
+++ linux-2.4.32-flash/drivers/mtd/maps/bcm947xx-flash.c 2005-12-19 01:29:52.464670750 +0100
|
|
@@ -0,0 +1,366 @@
|
|
+/*
|
|
+ * Copyright (C) 2004 Florian Schirmer (jolt@tuxbox.org)
|
|
+ * Copyright (C) 2005 Waldemar Brodkorb <wbx@openwrt.org>
|
|
+ *
|
|
+ * original functions for finding root filesystem from Mike Baker
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or modify it
|
|
+ * under the terms of the GNU General Public License as published by the
|
|
+ * Free Software Foundation; either version 2 of the License, or (at your
|
|
+ * option) any later version.
|
|
+ *
|
|
+ * THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESS OR IMPLIED
|
|
+ * WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
|
+ * MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN
|
|
+ * NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
|
|
+ * INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
|
|
+ * NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
|
|
+ * USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
|
|
+ * ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
|
+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
|
|
+ * THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
+ *
|
|
+ * You should have received a copy of the GNU General Public License along
|
|
+ * with this program; if not, write to the Free Software Foundation, Inc.,
|
|
+ * 675 Mass Ave, Cambridge, MA 02139, USA.
|
|
+ *
|
|
+ *
|
|
+ * Copyright 2004, Broadcom Corporation
|
|
+ * All Rights Reserved.
|
|
+ *
|
|
+ * THIS SOFTWARE IS OFFERED "AS IS", AND BROADCOM GRANTS NO WARRANTIES OF ANY
|
|
+ * KIND, EXPRESS OR IMPLIED, BY STATUTE, COMMUNICATION OR OTHERWISE. BROADCOM
|
|
+ * SPECIFICALLY DISCLAIMS ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS
|
|
+ * FOR A SPECIFIC PURPOSE OR NONINFRINGEMENT CONCERNING THIS SOFTWARE.
|
|
+ *
|
|
+ * Flash mapping for BCM947XX boards
|
|
+ *
|
|
+ */
|
|
+
|
|
+#include <linux/module.h>
|
|
+#include <linux/types.h>
|
|
+#include <linux/kernel.h>
|
|
+#include <asm/io.h>
|
|
+#include <linux/mtd/mtd.h>
|
|
+#include <linux/mtd/map.h>
|
|
+#ifdef CONFIG_MTD_PARTITIONS
|
|
+#include <linux/mtd/partitions.h>
|
|
+#endif
|
|
+#include <linux/config.h>
|
|
+
|
|
+#include <trxhdr.h>
|
|
+
|
|
+#define WINDOW_ADDR 0x1c000000
|
|
+#define WINDOW_SIZE (0x400000*2)
|
|
+#define BUSWIDTH 2
|
|
+
|
|
+static struct mtd_info *bcm947xx_mtd;
|
|
+
|
|
+__u8 bcm947xx_map_read8(struct map_info *map, unsigned long ofs)
|
|
+{
|
|
+ if (map->map_priv_2 == 1)
|
|
+ return __raw_readb(map->map_priv_1 + ofs);
|
|
+
|
|
+ u16 val = __raw_readw(map->map_priv_1 + (ofs & ~1));
|
|
+ if (ofs & 1)
|
|
+ return ((val >> 8) & 0xff);
|
|
+ else
|
|
+ return (val & 0xff);
|
|
+}
|
|
+
|
|
+__u16 bcm947xx_map_read16(struct map_info *map, unsigned long ofs)
|
|
+{
|
|
+ return __raw_readw(map->map_priv_1 + ofs);
|
|
+}
|
|
+
|
|
+__u32 bcm947xx_map_read32(struct map_info *map, unsigned long ofs)
|
|
+{
|
|
+ return __raw_readl(map->map_priv_1 + ofs);
|
|
+}
|
|
+
|
|
+void bcm947xx_map_copy_from(struct map_info *map, void *to, unsigned long from, ssize_t len)
|
|
+{
|
|
+ if (len==1) {
|
|
+ memcpy_fromio(to, map->map_priv_1 + from, len);
|
|
+ } else {
|
|
+ int i;
|
|
+ u16 *dest = (u16 *) to;
|
|
+ u16 *src = (u16 *) (map->map_priv_1 + from);
|
|
+ for (i = 0; i < (len / 2); i++) {
|
|
+ dest[i] = src[i];
|
|
+ }
|
|
+ if (len & 1)
|
|
+ *((u8 *)dest+len-1) = src[i] & 0xff;
|
|
+ }
|
|
+}
|
|
+
|
|
+void bcm947xx_map_write8(struct map_info *map, __u8 d, unsigned long adr)
|
|
+{
|
|
+ __raw_writeb(d, map->map_priv_1 + adr);
|
|
+ mb();
|
|
+}
|
|
+
|
|
+void bcm947xx_map_write16(struct map_info *map, __u16 d, unsigned long adr)
|
|
+{
|
|
+ __raw_writew(d, map->map_priv_1 + adr);
|
|
+ mb();
|
|
+}
|
|
+
|
|
+void bcm947xx_map_write32(struct map_info *map, __u32 d, unsigned long adr)
|
|
+{
|
|
+ __raw_writel(d, map->map_priv_1 + adr);
|
|
+ mb();
|
|
+}
|
|
+
|
|
+void bcm947xx_map_copy_to(struct map_info *map, unsigned long to, const void *from, ssize_t len)
|
|
+{
|
|
+ memcpy_toio(map->map_priv_1 + to, from, len);
|
|
+}
|
|
+
|
|
+struct map_info bcm947xx_map = {
|
|
+ name: "Physically mapped flash",
|
|
+ size: WINDOW_SIZE,
|
|
+ buswidth: BUSWIDTH,
|
|
+ read8: bcm947xx_map_read8,
|
|
+ read16: bcm947xx_map_read16,
|
|
+ read32: bcm947xx_map_read32,
|
|
+ copy_from: bcm947xx_map_copy_from,
|
|
+ write8: bcm947xx_map_write8,
|
|
+ write16: bcm947xx_map_write16,
|
|
+ write32: bcm947xx_map_write32,
|
|
+ copy_to: bcm947xx_map_copy_to
|
|
+};
|
|
+
|
|
+#ifdef CONFIG_MTD_PARTITIONS
|
|
+
|
|
+static struct mtd_partition bcm947xx_parts[] = {
|
|
+ { name: "cfe", offset: 0, size: 0, mask_flags: MTD_WRITEABLE, },
|
|
+ { name: "linux", offset: 0, size: 0, },
|
|
+ { name: "rootfs", offset: 0, size: 0, },
|
|
+ { name: "nvram", offset: 0, size: 0, },
|
|
+ { name: "OpenWrt", offset: 0, size: 0, },
|
|
+ { name: NULL, },
|
|
+};
|
|
+
|
|
+static int __init
|
|
+find_cfe_size(struct mtd_info *mtd, size_t size)
|
|
+{
|
|
+ struct trx_header *trx;
|
|
+ unsigned char buf[512];
|
|
+ int off;
|
|
+ size_t len;
|
|
+ int cfe_size_flag;
|
|
+
|
|
+ trx = (struct trx_header *) buf;
|
|
+
|
|
+ cfe_size_flag=0;
|
|
+
|
|
+ for (off = (256*1024); off < size; off += mtd->erasesize) {
|
|
+ memset(buf, 0xe5, sizeof(buf));
|
|
+
|
|
+ /*
|
|
+ * Read into buffer
|
|
+ */
|
|
+ if (MTD_READ(mtd, off, sizeof(buf), &len, buf) ||
|
|
+ len != sizeof(buf))
|
|
+ continue;
|
|
+
|
|
+ /* found a TRX header */
|
|
+ if (le32_to_cpu(trx->magic) == TRX_MAGIC) {
|
|
+ goto done;
|
|
+ }
|
|
+ cfe_size_flag += 1;
|
|
+ }
|
|
+
|
|
+ printk(KERN_NOTICE
|
|
+ "%s: Couldn't find bootloader size\n",
|
|
+ mtd->name);
|
|
+ return -1;
|
|
+
|
|
+ done:
|
|
+ printk(KERN_NOTICE "bootloader size flag: %d\n", cfe_size_flag);
|
|
+ return cfe_size_flag;
|
|
+
|
|
+}
|
|
+
|
|
+static int __init
|
|
+find_root(struct mtd_info *mtd, size_t size, struct mtd_partition *part)
|
|
+{
|
|
+ struct trx_header *trx;
|
|
+ unsigned char buf[512];
|
|
+ int off;
|
|
+ size_t len;
|
|
+
|
|
+ trx = (struct trx_header *) buf;
|
|
+
|
|
+ for (off = (256*1024); off < size; off += mtd->erasesize) {
|
|
+ memset(buf, 0xe5, sizeof(buf));
|
|
+
|
|
+ /*
|
|
+ * Read into buffer
|
|
+ */
|
|
+ if (MTD_READ(mtd, off, sizeof(buf), &len, buf) ||
|
|
+ len != sizeof(buf))
|
|
+ continue;
|
|
+
|
|
+ /* found a TRX header */
|
|
+ if (le32_to_cpu(trx->magic) == TRX_MAGIC) {
|
|
+ part->offset = le32_to_cpu(trx->offsets[2]) ? :
|
|
+ le32_to_cpu(trx->offsets[1]);
|
|
+ part->size = le32_to_cpu(trx->len);
|
|
+
|
|
+ part->size -= part->offset;
|
|
+ part->offset += off;
|
|
+
|
|
+ goto done;
|
|
+ }
|
|
+ }
|
|
+
|
|
+ printk(KERN_NOTICE
|
|
+ "%s: Couldn't find root filesystem\n",
|
|
+ mtd->name);
|
|
+ return -1;
|
|
+
|
|
+ done:
|
|
+ return part->size;
|
|
+}
|
|
+
|
|
+struct mtd_partition * __init
|
|
+init_mtd_partitions(struct mtd_info *mtd, size_t size)
|
|
+{
|
|
+
|
|
+ int cfe_size_flag;
|
|
+
|
|
+ /* if cfe_size_flag=0, cfe size is 256 kb, else 384 kb */
|
|
+ cfe_size_flag = find_cfe_size(mtd,size);
|
|
+
|
|
+ /* boot loader */
|
|
+ bcm947xx_parts[0].offset = 0;
|
|
+ if (cfe_size_flag == 0) {
|
|
+ bcm947xx_parts[0].size = 1024*256;
|
|
+ } else {
|
|
+ /* netgear wgt634u has 384 kb bootloader */
|
|
+ bcm947xx_parts[0].size = 1024*384;
|
|
+ }
|
|
+
|
|
+ /* nvram */
|
|
+ if (cfe_size_flag == 0) {
|
|
+ bcm947xx_parts[3].offset = size - mtd->erasesize;
|
|
+ } else {
|
|
+ /* nvram (old 128kb config partition on netgear wgt634u) */
|
|
+ bcm947xx_parts[3].offset = bcm947xx_parts[0].size;
|
|
+ }
|
|
+ bcm947xx_parts[3].size = mtd->erasesize;
|
|
+
|
|
+ /* linux (kernel and rootfs) */
|
|
+ if (cfe_size_flag == 0) {
|
|
+ bcm947xx_parts[1].offset = bcm947xx_parts[0].size;
|
|
+ bcm947xx_parts[1].size = bcm947xx_parts[3].offset -
|
|
+ bcm947xx_parts[1].offset;
|
|
+ } else {
|
|
+ /* do not count the elf loader, which is on one block */
|
|
+ bcm947xx_parts[1].offset = bcm947xx_parts[0].size +
|
|
+ bcm947xx_parts[3].size + mtd->erasesize;
|
|
+ bcm947xx_parts[1].size = size -
|
|
+ bcm947xx_parts[0].size -
|
|
+ (2*bcm947xx_parts[3].size) -
|
|
+ mtd->erasesize;
|
|
+ }
|
|
+
|
|
+ /* find and size rootfs */
|
|
+ if (find_root(mtd,size,&bcm947xx_parts[2])==0) {
|
|
+ /* entirely jffs2 */
|
|
+ bcm947xx_parts[4].name = NULL;
|
|
+ bcm947xx_parts[2].size = size - bcm947xx_parts[2].offset -
|
|
+ bcm947xx_parts[3].size;
|
|
+ } else {
|
|
+ /* legacy setup */
|
|
+ /* calculate leftover flash, and assign it to the jffs2 partition */
|
|
+ if (cfe_size_flag == 0) {
|
|
+ bcm947xx_parts[4].offset = bcm947xx_parts[2].offset +
|
|
+ bcm947xx_parts[2].size;
|
|
+ if ((bcm947xx_parts[4].offset % mtd->erasesize) > 0) {
|
|
+ bcm947xx_parts[4].offset += mtd->erasesize -
|
|
+ (bcm947xx_parts[4].offset % mtd->erasesize);
|
|
+ }
|
|
+ bcm947xx_parts[4].size = bcm947xx_parts[3].offset -
|
|
+ bcm947xx_parts[4].offset;
|
|
+ } else {
|
|
+ bcm947xx_parts[4].offset = bcm947xx_parts[2].offset +
|
|
+ bcm947xx_parts[2].size;
|
|
+ if ((bcm947xx_parts[4].offset % mtd->erasesize) > 0) {
|
|
+ bcm947xx_parts[4].offset += mtd->erasesize -
|
|
+ (bcm947xx_parts[4].offset % mtd->erasesize);
|
|
+ }
|
|
+ bcm947xx_parts[4].size = size - bcm947xx_parts[3].size -
|
|
+ bcm947xx_parts[4].offset;
|
|
+ }
|
|
+ }
|
|
+
|
|
+ return bcm947xx_parts;
|
|
+}
|
|
+
|
|
+#endif
|
|
+
|
|
+
|
|
+mod_init_t init_bcm947xx_map(void)
|
|
+{
|
|
+ size_t size;
|
|
+ int ret = 0;
|
|
+#ifdef CONFIG_MTD_PARTITIONS
|
|
+ struct mtd_partition *parts;
|
|
+ int i;
|
|
+#endif
|
|
+
|
|
+ bcm947xx_map.map_priv_1 = (unsigned long) ioremap(WINDOW_ADDR, WINDOW_SIZE);
|
|
+
|
|
+ if (!bcm947xx_map.map_priv_1) {
|
|
+ printk(KERN_ERR "Failed to ioremap\n");
|
|
+ return -EIO;
|
|
+ }
|
|
+
|
|
+ if (!(bcm947xx_mtd = do_map_probe("cfi_probe", &bcm947xx_map))) {
|
|
+ printk(KERN_ERR "pflash: cfi_probe failed\n");
|
|
+ iounmap((void *)bcm947xx_map.map_priv_1);
|
|
+ return -ENXIO;
|
|
+ }
|
|
+
|
|
+ bcm947xx_mtd->module = THIS_MODULE;
|
|
+
|
|
+ size = bcm947xx_mtd->size;
|
|
+
|
|
+ printk(KERN_NOTICE "Flash device: 0x%x at 0x%x\n", size, WINDOW_ADDR);
|
|
+
|
|
+#ifdef CONFIG_MTD_PARTITIONS
|
|
+ parts = init_mtd_partitions(bcm947xx_mtd, size);
|
|
+ for (i = 0; parts[i].name; i++);
|
|
+ ret = add_mtd_partitions(bcm947xx_mtd, parts, i);
|
|
+ if (ret) {
|
|
+ printk(KERN_ERR "Flash: add_mtd_partitions failed\n");
|
|
+ goto fail;
|
|
+ }
|
|
+#endif
|
|
+
|
|
+ return 0;
|
|
+
|
|
+ fail:
|
|
+ if (bcm947xx_mtd)
|
|
+ map_destroy(bcm947xx_mtd);
|
|
+ if (bcm947xx_map.map_priv_1)
|
|
+ iounmap((void *) bcm947xx_map.map_priv_1);
|
|
+ bcm947xx_map.map_priv_1 = 0;
|
|
+ return ret;
|
|
+}
|
|
+
|
|
+mod_exit_t cleanup_bcm947xx_map(void)
|
|
+{
|
|
+#ifdef CONFIG_MTD_PARTITIONS
|
|
+ del_mtd_partitions(bcm947xx_mtd);
|
|
+#endif
|
|
+ map_destroy(bcm947xx_mtd);
|
|
+ iounmap((void *) bcm947xx_map.map_priv_1);
|
|
+ bcm947xx_map.map_priv_1 = 0;
|
|
+}
|
|
+
|
|
+module_init(init_bcm947xx_map);
|
|
+module_exit(cleanup_bcm947xx_map);
|
|
diff -Nur linux-2.4.32/drivers/mtd/maps/Config.in linux-2.4.32-flash/drivers/mtd/maps/Config.in
|
|
--- linux-2.4.32/drivers/mtd/maps/Config.in 2003-06-13 16:51:34.000000000 +0200
|
|
+++ linux-2.4.32-flash/drivers/mtd/maps/Config.in 2005-12-18 15:53:52.003277250 +0100
|
|
@@ -48,6 +48,7 @@
|
|
fi
|
|
|
|
if [ "$CONFIG_MIPS" = "y" ]; then
|
|
+ dep_tristate ' CFI Flash device mapped on Broadcom BCM947XX boards' CONFIG_MTD_BCM947XX $CONFIG_MTD_CFI
|
|
dep_tristate ' Pb1000 MTD support' CONFIG_MTD_PB1000 $CONFIG_MIPS_PB1000
|
|
dep_tristate ' Pb1500 MTD support' CONFIG_MTD_PB1500 $CONFIG_MIPS_PB1500
|
|
dep_tristate ' Pb1100 MTD support' CONFIG_MTD_PB1100 $CONFIG_MIPS_PB1100
|
|
diff -Nur linux-2.4.32/drivers/mtd/maps/Makefile linux-2.4.32-flash/drivers/mtd/maps/Makefile
|
|
--- linux-2.4.32/drivers/mtd/maps/Makefile 2003-06-13 16:51:34.000000000 +0200
|
|
+++ linux-2.4.32-flash/drivers/mtd/maps/Makefile 2005-12-18 15:54:39.022215750 +0100
|
|
@@ -3,6 +3,8 @@
|
|
#
|
|
# $Id: Makefile,v 1.37 2003/01/24 14:26:38 dwmw2 Exp $
|
|
|
|
+EXTRA_CFLAGS := -I$(TOPDIR)/arch/mips/bcm947xx/include
|
|
+
|
|
BELOW25 := $(shell echo $(PATCHLEVEL) | sed s/[1234]/y/)
|
|
|
|
ifeq ($(BELOW25),y)
|
|
@@ -10,6 +12,7 @@
|
|
endif
|
|
|
|
# Chip mappings
|
|
+obj-$(CONFIG_MTD_BCM947XX) += bcm947xx-flash.o
|
|
obj-$(CONFIG_MTD_CDB89712) += cdb89712.o
|
|
obj-$(CONFIG_MTD_ARM_INTEGRATOR)+= integrator-flash.o
|
|
obj-$(CONFIG_MTD_CFI_FLAGADM) += cfi_flagadm.o
|