mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 21:20:37 +02:00
da1bd2aad6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27310 3c298f89-4303-0410-b956-a3cf2f4a3e73
26 lines
816 B
Diff
26 lines
816 B
Diff
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -317,6 +317,12 @@ config SPI_PXA2XX
|
|
config SPI_PXA2XX_PCI
|
|
def_bool SPI_PXA2XX && X86_32 && PCI
|
|
|
|
+config SPI_RB4XX
|
|
+ tristate "Mikrotik RB4XX SPI master"
|
|
+ depends on SPI_MASTER && AR71XX_MACH_RB4XX
|
|
+ help
|
|
+ SPI controller driver for the Mikrotik RB4xx series boards.
|
|
+
|
|
config SPI_S3C24XX
|
|
tristate "Samsung S3C24XX series SPI"
|
|
depends on ARCH_S3C2410 && EXPERIMENTAL
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -56,6 +56,7 @@ obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.
|
|
obj-$(CONFIG_SPI_SH_MSIOF) += spi_sh_msiof.o
|
|
obj-$(CONFIG_SPI_STMP3XXX) += spi_stmp.o
|
|
obj-$(CONFIG_SPI_NUC900) += spi_nuc900.o
|
|
+obj-$(CONFIG_SPI_RB4XX) += rb4xx_spi.o
|
|
|
|
# special build for s3c24xx spi driver with fiq support
|
|
spi_s3c24xx_hw-y := spi_s3c24xx.o
|