mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 21:38:26 +02:00
33ec8951f8
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30410 3c298f89-4303-0410-b956-a3cf2f4a3e73
25 lines
729 B
Diff
25 lines
729 B
Diff
--- a/drivers/net/dsa/Kconfig
|
|
+++ b/drivers/net/dsa/Kconfig
|
|
@@ -12,6 +12,13 @@ config NET_DSA_MV88E6060
|
|
This enables support for the Marvell 88E6060 ethernet switch
|
|
chip.
|
|
|
|
+config NET_DSA_MV88E6063
|
|
+ bool "Marvell 88E6063 ethernet switch chip support"
|
|
+ select NET_DSA_TAG_TRAILER
|
|
+ ---help---
|
|
+ This enables support for the Marvell 88E6063 ethernet switch
|
|
+ chip
|
|
+
|
|
config NET_DSA_MV88E6XXX_NEED_PPU
|
|
bool
|
|
default n
|
|
--- a/drivers/net/dsa/Makefile
|
|
+++ b/drivers/net/dsa/Makefile
|
|
@@ -1,4 +1,5 @@
|
|
obj-$(CONFIG_NET_DSA_MV88E6060) += mv88e6060.o
|
|
+obj-$(CONFIG_NET_DSA_MV88E6063) += mv88e6063.o
|
|
obj-$(CONFIG_NET_DSA_MV88E6XXX) += mv88e6xxx_drv.o
|
|
mv88e6xxx_drv-y += mv88e6xxx.o
|
|
ifdef CONFIG_NET_DSA_MV88E6123_61_65
|