mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 20:22:48 +02:00
9b31379ed2
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9373 3c298f89-4303-0410-b956-a3cf2f4a3e73
209 lines
7.5 KiB
Diff
209 lines
7.5 KiB
Diff
Index: linux-atm-2.4.1/src/qgen/Makefile.am
|
|
===================================================================
|
|
--- linux-atm-2.4.1.orig/src/qgen/Makefile.am 2007-10-20 19:19:10.354218533 +0200
|
|
+++ linux-atm-2.4.1/src/qgen/Makefile.am 2007-10-20 19:19:16.814586679 +0200
|
|
@@ -3,7 +3,7 @@
|
|
|
|
qgen_SOURCES = common.c common.h file.c file.h first.c ql_y.y ql_l.l qgen.c \
|
|
qgen.h second.c third.c
|
|
-qgen_LDADD = -lfl
|
|
+qgen_LDADD =
|
|
|
|
q_dump_SOURCES = common.c
|
|
q_dump_LDADD = qd.dump.standalone.o
|
|
Index: linux-atm-2.4.1/src/qgen/Makefile.in
|
|
===================================================================
|
|
--- linux-atm-2.4.1.orig/src/qgen/Makefile.in 2007-10-20 19:19:11.898306522 +0200
|
|
+++ linux-atm-2.4.1/src/qgen/Makefile.in 2007-10-20 19:19:16.814586679 +0200
|
|
@@ -90,7 +90,7 @@
|
|
|
|
qgen_SOURCES = common.c common.h file.c file.h first.c ql_y.y ql_l.l qgen.c qgen.h second.c third.c
|
|
|
|
-qgen_LDADD = -lfl
|
|
+qgen_LDADD =
|
|
|
|
q_dump_SOURCES = common.c
|
|
q_dump_LDADD = qd.dump.standalone.o
|
|
Index: linux-atm-2.4.1/src/qgen/ql_l.c
|
|
===================================================================
|
|
--- linux-atm-2.4.1.orig/src/qgen/ql_l.c 2007-10-20 19:19:11.906306980 +0200
|
|
+++ linux-atm-2.4.1/src/qgen/ql_l.c 2007-10-20 19:19:16.842588278 +0200
|
|
@@ -501,6 +501,11 @@
|
|
#include "qgen.h"
|
|
#include "ql_y.h"
|
|
|
|
+int yywrap(void)
|
|
+{
|
|
+ return 1;
|
|
+}
|
|
+
|
|
|
|
typedef struct _tree {
|
|
struct _tree *left,*right;
|
|
Index: linux-atm-2.4.1/src/sigd/cfg_l.c
|
|
===================================================================
|
|
--- linux-atm-2.4.1.orig/src/sigd/cfg_l.c 2007-10-20 19:19:10.378219897 +0200
|
|
+++ linux-atm-2.4.1/src/sigd/cfg_l.c 2007-10-20 19:19:16.854588969 +0200
|
|
@@ -11,6 +11,10 @@
|
|
#include <stdio.h>
|
|
#include <unistd.h>
|
|
|
|
+int yywrap(void)
|
|
+{
|
|
+ return 1;
|
|
+}
|
|
|
|
/* cfront 1.2 defines "c_plusplus" instead of "__cplusplus" */
|
|
#ifdef c_plusplus
|
|
Index: linux-atm-2.4.1/src/sigd/Makefile.am
|
|
===================================================================
|
|
--- linux-atm-2.4.1.orig/src/sigd/Makefile.am 2007-10-20 19:19:10.386220355 +0200
|
|
+++ linux-atm-2.4.1/src/sigd/Makefile.am 2007-10-20 19:19:16.882590565 +0200
|
|
@@ -8,7 +8,7 @@
|
|
$(top_builddir)/src/qgen/qd.dump.o \
|
|
$(top_builddir)/src/lib/libatm.la \
|
|
$(top_builddir)/src/saal/libsaal.a
|
|
-atmsigd_LDADD = $(atmsigd_XTRAS) -lfl
|
|
+atmsigd_LDADD = $(atmsigd_XTRAS)
|
|
atmsigd_DEPENDENCIES = mess.c $(atmsigd_XTRAS)
|
|
|
|
CLEANFILES = mess.c
|
|
Index: linux-atm-2.4.1/src/sigd/Makefile.in
|
|
===================================================================
|
|
--- linux-atm-2.4.1.orig/src/sigd/Makefile.in 2007-10-20 19:19:12.018313361 +0200
|
|
+++ linux-atm-2.4.1/src/sigd/Makefile.in 2007-10-20 19:19:16.886590795 +0200
|
|
@@ -92,7 +92,7 @@
|
|
|
|
atmsigd_XTRAS = mess.o $(top_builddir)/src/qgen/q.out.o $(top_builddir)/src/qgen/qd.dump.o $(top_builddir)/src/lib/libatm.la $(top_builddir)/src/saal/libsaal.a
|
|
|
|
-atmsigd_LDADD = $(atmsigd_XTRAS) -lfl
|
|
+atmsigd_LDADD = $(atmsigd_XTRAS)
|
|
atmsigd_DEPENDENCIES = mess.c $(atmsigd_XTRAS)
|
|
|
|
CLEANFILES = mess.c
|
|
Index: linux-atm-2.4.1/src/switch/debug/debug.c
|
|
===================================================================
|
|
--- linux-atm-2.4.1.orig/src/switch/debug/debug.c 2007-10-20 19:19:12.414335932 +0200
|
|
+++ linux-atm-2.4.1/src/switch/debug/debug.c 2007-10-20 19:19:16.894591246 +0200
|
|
@@ -20,6 +20,11 @@
|
|
|
|
#define PRV(call) ((FAB *) (call)->fab)
|
|
|
|
+int yywrap(void)
|
|
+{
|
|
+ return 1;
|
|
+}
|
|
+
|
|
|
|
typedef struct _fab {
|
|
CALL *next; /* relay.c may not keep track of calls, but WE are */
|
|
Index: linux-atm-2.4.1/src/switch/debug/Makefile.am
|
|
===================================================================
|
|
--- linux-atm-2.4.1.orig/src/switch/debug/Makefile.am 2007-10-20 19:19:10.406221495 +0200
|
|
+++ linux-atm-2.4.1/src/switch/debug/Makefile.am 2007-10-20 19:19:16.906591931 +0200
|
|
@@ -5,7 +5,7 @@
|
|
sw_debug_SOURCES = debug.c
|
|
sw_debug_XTRAS = $(top_builddir)/src/switch/libsw.a \
|
|
$(top_builddir)/src/lib/libatm.la
|
|
-sw_debug_LDADD = $(sw_debug_XTRAS) -lfl
|
|
+sw_debug_LDADD = $(sw_debug_XTRAS)
|
|
|
|
sw_debug_DEPENDENCIES = $(sw_debug_XTRAS)
|
|
|
|
Index: linux-atm-2.4.1/src/switch/debug/Makefile.in
|
|
===================================================================
|
|
--- linux-atm-2.4.1.orig/src/switch/debug/Makefile.in 2007-10-20 19:19:12.378333877 +0200
|
|
+++ linux-atm-2.4.1/src/switch/debug/Makefile.in 2007-10-20 19:19:16.918592613 +0200
|
|
@@ -92,7 +92,7 @@
|
|
sw_debug_SOURCES = debug.c
|
|
sw_debug_XTRAS = $(top_builddir)/src/switch/libsw.a $(top_builddir)/src/lib/libatm.la
|
|
|
|
-sw_debug_LDADD = $(sw_debug_XTRAS) -lfl
|
|
+sw_debug_LDADD = $(sw_debug_XTRAS)
|
|
|
|
sw_debug_DEPENDENCIES = $(sw_debug_XTRAS)
|
|
|
|
Index: linux-atm-2.4.1/src/switch/tcp/Makefile.am
|
|
===================================================================
|
|
--- linux-atm-2.4.1.orig/src/switch/tcp/Makefile.am 2007-10-20 19:19:10.422222406 +0200
|
|
+++ linux-atm-2.4.1/src/switch/tcp/Makefile.am 2007-10-20 19:19:16.922592837 +0200
|
|
@@ -5,7 +5,7 @@
|
|
sw_tcp_SOURCES = tcpsw.c
|
|
sw_tcp_XTRAS = $(top_builddir)/src/switch/libsw.a \
|
|
$(top_builddir)/src/lib/libatm.la
|
|
-sw_tcp_LDADD = $(sw_tcp_XTRAS) -lfl
|
|
+sw_tcp_LDADD = $(sw_tcp_XTRAS)
|
|
sw_tcp_DEPENDENCIES = $(sw_tcp_XTRAS)
|
|
|
|
EXTRA_DIST = mkfiles README
|
|
Index: linux-atm-2.4.1/src/switch/tcp/Makefile.in
|
|
===================================================================
|
|
--- linux-atm-2.4.1.orig/src/switch/tcp/Makefile.in 2007-10-20 19:19:12.422336385 +0200
|
|
+++ linux-atm-2.4.1/src/switch/tcp/Makefile.in 2007-10-20 19:19:16.926593064 +0200
|
|
@@ -92,7 +92,7 @@
|
|
sw_tcp_SOURCES = tcpsw.c
|
|
sw_tcp_XTRAS = $(top_builddir)/src/switch/libsw.a $(top_builddir)/src/lib/libatm.la
|
|
|
|
-sw_tcp_LDADD = $(sw_tcp_XTRAS) -lfl
|
|
+sw_tcp_LDADD = $(sw_tcp_XTRAS)
|
|
sw_tcp_DEPENDENCIES = $(sw_tcp_XTRAS)
|
|
|
|
EXTRA_DIST = mkfiles README
|
|
Index: linux-atm-2.4.1/src/switch/tcp/tcpsw.c
|
|
===================================================================
|
|
--- linux-atm-2.4.1.orig/src/switch/tcp/tcpsw.c 2007-10-20 19:19:12.426336614 +0200
|
|
+++ linux-atm-2.4.1/src/switch/tcp/tcpsw.c 2007-10-20 19:19:16.954594660 +0200
|
|
@@ -35,6 +35,10 @@
|
|
#define MAX_PACKET (ATM_MAX_AAL5_PDU+sizeof(struct atmtcp_hdr))
|
|
#define BUFFER_SIZE (MAX_PACKET*2)
|
|
|
|
+int yywrap(void)
|
|
+{
|
|
+ return 1;
|
|
+}
|
|
|
|
typedef struct _table {
|
|
struct _link *out; /* output port */
|
|
Index: linux-atm-2.4.1/src/test/ispl_l.c
|
|
===================================================================
|
|
--- linux-atm-2.4.1.orig/src/test/ispl_l.c 2007-10-20 19:19:10.442223546 +0200
|
|
+++ linux-atm-2.4.1/src/test/ispl_l.c 2007-10-20 19:19:16.962595124 +0200
|
|
@@ -11,6 +11,11 @@
|
|
#include <stdio.h>
|
|
#include <unistd.h>
|
|
|
|
+int yywrap(void)
|
|
+{
|
|
+ return 1;
|
|
+}
|
|
+
|
|
|
|
/* cfront 1.2 defines "c_plusplus" instead of "__cplusplus" */
|
|
#ifdef c_plusplus
|
|
Index: linux-atm-2.4.1/src/test/Makefile.am
|
|
===================================================================
|
|
--- linux-atm-2.4.1.orig/src/test/Makefile.am 2007-10-20 19:19:11.858304242 +0200
|
|
+++ linux-atm-2.4.1/src/test/Makefile.am 2007-10-20 19:19:16.962595124 +0200
|
|
@@ -15,7 +15,7 @@
|
|
bw_SOURCES = bw.c
|
|
isp_SOURCES = isp.c isp.h ispl_y.y ispl_l.l
|
|
isp_XTRAS = $(LDADD)
|
|
-isp_LDADD = $(isp_XTRAS) -lfl
|
|
+isp_LDADD = $(isp_XTRAS)
|
|
isp_DEPENDENCIES = $(isp_XTRAS) errnos.inc
|
|
window_SOURCES = window.c
|
|
|
|
Index: linux-atm-2.4.1/src/test/Makefile.in
|
|
===================================================================
|
|
--- linux-atm-2.4.1.orig/src/test/Makefile.in 2007-10-20 19:19:11.826302420 +0200
|
|
+++ linux-atm-2.4.1/src/test/Makefile.in 2007-10-20 19:19:16.962595124 +0200
|
|
@@ -102,7 +102,7 @@
|
|
bw_SOURCES = bw.c
|
|
isp_SOURCES = isp.c isp.h ispl_y.y ispl_l.l
|
|
isp_XTRAS = $(LDADD)
|
|
-isp_LDADD = $(isp_XTRAS) -lfl
|
|
+isp_LDADD = $(isp_XTRAS)
|
|
isp_DEPENDENCIES = $(isp_XTRAS) errnos.inc
|
|
window_SOURCES = window.c
|
|
|