mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 19:06:16 +02:00
91ddf2fe5b
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19960 3c298f89-4303-0410-b956-a3cf2f4a3e73
25 lines
745 B
Diff
25 lines
745 B
Diff
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -365,6 +365,11 @@ config SPI_TLE62X0
|
|
sysfs interface, with each line presented as a kind of GPIO
|
|
exposing both switch control and diagnostic feedback.
|
|
|
|
+config SPI_VSC7385
|
|
+ tristate "Vitesse VSC7385 ethernet switch driver"
|
|
+ help
|
|
+ SPI driver for the Vitesse VSC7385 ethernet switch.
|
|
+
|
|
#
|
|
# Add new SPI protocol masters in alphabetical order above this line
|
|
#
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -54,6 +54,7 @@ spi_s3c24xx_hw-$(CONFIG_SPI_S3C24XX_FIQ)
|
|
|
|
# SPI protocol drivers (device/link on bus)
|
|
obj-$(CONFIG_SPI_SPIDEV) += spidev.o
|
|
+obj-$(CONFIG_SPI_VSC7385) += spi_vsc7385.o
|
|
obj-$(CONFIG_SPI_TLE62X0) += tle62x0.o
|
|
# ... add above this line ...
|
|
|