mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-05 13:30:38 +02:00
2bdf759d68
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21372 3c298f89-4303-0410-b956-a3cf2f4a3e73
24 lines
1.0 KiB
Diff
24 lines
1.0 KiB
Diff
Index: linux-2.6.30.10/scripts/Makefile.lib
|
|
===================================================================
|
|
--- linux-2.6.30.10.orig/scripts/Makefile.lib 2010-05-05 10:55:06.000000000 +0200
|
|
+++ linux-2.6.30.10/scripts/Makefile.lib 2010-05-05 10:55:55.000000000 +0200
|
|
@@ -204,4 +204,4 @@
|
|
# ---------------------------------------------------------------------------
|
|
|
|
quiet_cmd_lzma = LZMA $@
|
|
-cmd_lzma = lzma e $< $@ -lc1 -lp2 -pb2 -eos
|
|
+cmd_lzma = lzma e $< $@ -lc8 -eos
|
|
Index: linux-2.6.30.10/arch/x86/include/asm/boot.h
|
|
===================================================================
|
|
--- linux-2.6.30.10.orig/arch/x86/include/asm/boot.h 2009-12-04 07:00:07.000000000 +0100
|
|
+++ linux-2.6.30.10/arch/x86/include/asm/boot.h 2010-05-05 10:55:23.000000000 +0200
|
|
@@ -13,7 +13,7 @@
|
|
+ (CONFIG_PHYSICAL_ALIGN - 1)) \
|
|
& ~(CONFIG_PHYSICAL_ALIGN - 1))
|
|
|
|
-#ifdef CONFIG_KERNEL_BZIP2
|
|
+#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
|
|
#define BOOT_HEAP_SIZE 0x400000
|
|
#else /* !CONFIG_KERNEL_BZIP2 */
|
|
|