mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 16:34:05 +02:00
dfba2f5fb1
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26746 3c298f89-4303-0410-b956-a3cf2f4a3e73
28 lines
877 B
Diff
28 lines
877 B
Diff
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -9,6 +9,7 @@ ccflags-$(CONFIG_SPI_DEBUG) := -DDEBUG
|
|
obj-$(CONFIG_SPI_MASTER) += spi.o
|
|
|
|
# SPI master controller drivers (bus)
|
|
+obj-$(CONFIG_SPI_AP83) += ap83_spi.o
|
|
obj-$(CONFIG_SPI_AR71XX) += ar71xx_spi.o
|
|
obj-$(CONFIG_SPI_ATMEL) += atmel_spi.o
|
|
obj-$(CONFIG_SPI_ATH79) += ath79_spi.o
|
|
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -61,6 +61,14 @@ config SPI_ATH79
|
|
This enables support for the SPI controller present on the
|
|
Atheros AR71XX/AR724X/AR913X SoCs.
|
|
|
|
+config SPI_AP83
|
|
+ tristate "Atheros AP83 specific SPI Controller"
|
|
+ depends on SPI_MASTER && AR71XX_MACH_AP83
|
|
+ select SPI_BITBANG
|
|
+ help
|
|
+ This is a specific SPI controller driver for the Atheros AP83
|
|
+ reference board.
|
|
+
|
|
config SPI_AR71XX
|
|
tristate "Atheros AR71xx SPI Controller"
|
|
depends on SPI_MASTER && ATHEROS_AR71XX
|