1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 12:06:49 +03:00
openwrt-xburst/target/linux/rdc-2.6/patches/002-r6040_ethernet.patch
florian 8ce9e8a9b1 NAPI for r6040 of course depends on r6040
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8161 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-07-25 15:09:35 +00:00

40 lines
1.5 KiB
Diff

diff -urN linux-2.6.17/drivers/net/Kconfig linux-2.6.17.new/drivers/net/Kconfig
--- linux-2.6.17/drivers/net/Kconfig 2006-06-18 03:49:35.000000000 +0200
+++ linux-2.6.17.new/drivers/net/Kconfig 2006-09-25 13:14:27.000000000 +0200
@@ -1358,6 +1358,24 @@
<file:Documentation/networking/net-modules.txt>. The module will be
called apricot.
+config R6040
+ tristate "RDC Fast-Ethernet support (EXPERIMENTAL)"
+ depends on NET_PCI && EXPERIMENTAL
+ select MII
+ help
+ If you have a network (Ethernet) controller of this type, say Y and
+ read the Ethernet-HOWTO, available from
+ <http://www.tldp.org/docs.html#howto>.
+
+ To compile this driver as a module, choose M here and read
+ <file:Documentation/networking/net-modules.txt>. The module will be
+ called r6040.
+
+
+config R6040_NAPI
+ bool "NAPI support for R6040"
+ depends on R6040
+ default y
config B44
tristate "Broadcom 4400 ethernet support (EXPERIMENTAL)"
depends on NET_PCI && PCI && EXPERIMENTAL
diff -urN linux-2.6.17/drivers/net/Makefile linux-2.6.17.new/drivers/net/Makefile
--- linux-2.6.17/drivers/net/Makefile 2006-06-18 03:49:35.000000000 +0200
+++ linux-2.6.17.new/drivers/net/Makefile 2006-09-25 13:14:45.000000000 +0200
@@ -106,6 +106,7 @@
obj-$(CONFIG_NE3210) += ne3210.o 8390.o
obj-$(CONFIG_NET_SB1250_MAC) += sb1250-mac.o
obj-$(CONFIG_B44) += b44.o
+obj-$(CONFIG_R6040) += r6040.o
obj-$(CONFIG_FORCEDETH) += forcedeth.o
obj-$(CONFIG_NE_H8300) += ne-h8300.o 8390.o