1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 14:03:41 +03:00
openwrt-xburst/target/linux/rb532/patches/120-cf.patch
juhosg 468bd06707 [rb532] refresh kernel patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11203 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-19 09:07:27 +00:00

32 lines
1.1 KiB
Diff

Index: linux-2.6.23.17/drivers/block/Kconfig
===================================================================
--- linux-2.6.23.17.orig/drivers/block/Kconfig
+++ linux-2.6.23.17/drivers/block/Kconfig
@@ -426,6 +426,14 @@ config SUNVDC
Support for virtual disk devices as a client under Sun
Logical Domains.
+config BLK_DEV_CF_MIPS
+ bool "CF slot of RB532 board"
+ depends on MIKROTIK_RB500
+ default y
+ help
+ The Routerboard 532 has a CF slot on it. Enable the special block
+ device driver for it.
+
source "drivers/s390/block/Kconfig"
config XILINX_SYSACE
Index: linux-2.6.23.17/drivers/block/Makefile
===================================================================
--- linux-2.6.23.17.orig/drivers/block/Makefile
+++ linux-2.6.23.17/drivers/block/Makefile
@@ -21,6 +21,7 @@ obj-$(CONFIG_BLK_DEV_DAC960) += DAC960.o
obj-$(CONFIG_XILINX_SYSACE) += xsysace.o
obj-$(CONFIG_CDROM_PKTCDVD) += pktcdvd.o
obj-$(CONFIG_SUNVDC) += sunvdc.o
+obj-$(CONFIG_BLK_DEV_CF_MIPS) += rb500/
obj-$(CONFIG_BLK_DEV_UMEM) += umem.o
obj-$(CONFIG_BLK_DEV_NBD) += nbd.o