1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 14:03:41 +03:00
openwrt-xburst/target/linux/rb532/patches/510-rb500_led.patch
juhosg 468bd06707 [rb532] refresh kernel patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11203 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-19 09:07:27 +00:00

30 lines
1.1 KiB
Diff

Index: linux-2.6.23.17/drivers/leds/Kconfig
===================================================================
--- linux-2.6.23.17.orig/drivers/leds/Kconfig
+++ linux-2.6.23.17/drivers/leds/Kconfig
@@ -107,6 +107,12 @@ config LEDS_GPIO
outputs. To be useful the particular board must have LEDs
and they must be connected to the GPIO lines.
+config LEDS_RB500
+ tristate "LED Support for RB5xx boards"
+ depends LEDS_CLASS && MIKROTIK_RB500
+ help
+ This option enables support for the yellow user LED on RB5xx boards.
+
comment "LED Triggers"
config LEDS_TRIGGERS
Index: linux-2.6.23.17/drivers/leds/Makefile
===================================================================
--- linux-2.6.23.17.orig/drivers/leds/Makefile
+++ linux-2.6.23.17/drivers/leds/Makefile
@@ -18,6 +18,7 @@ obj-$(CONFIG_LEDS_ALIX) += leds-alix.o
obj-$(CONFIG_LEDS_H1940) += leds-h1940.o
obj-$(CONFIG_LEDS_COBALT) += leds-cobalt.o
obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o
+obj-$(CONFIG_LEDS_RB500) += leds-rb500.o
# LED Triggers
obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o