1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-10-27 16:17:32 +02:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.27/004-extra_optimization.patch
nbd 5951d03bc4 port generic and ixp4xx kernel patches to 2.6.27 (compiles except for iptables, but otherwise completely untested)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12790 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-09-29 01:08:17 +00:00

13 lines
359 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -549,6 +549,9 @@
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)