1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-08 04:32:21 +03:00
openwrt-xburst/toolchain/uClibc/patches/150-portability.patch
nbd c6c7fea2b9 Fix portability patch for uClibc.
Certain versions of GNU cp treat -P as --parent, which is wrong here and -P should be implied by -R already.
Fixes build on OSX with fink's fileutils installed.


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6784 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-04-01 11:43:11 +00:00

30 lines
1.2 KiB
Diff

Fix portability of build infrastructure
* cp -d -> cp -P
* tar --exclude is a GNU tar feature
--- uClibc-0.9.28/Makefile.orig Sun Jun 11 19:08:56 2006
+++ uClibc-0.9.28/Makefile Sun Jun 11 19:12:05 2006
@@ -158,12 +158,7 @@ install_dev:
$(INSTALL) -d $(PREFIX)$(DEVEL_PREFIX)lib
$(INSTALL) -d $(PREFIX)$(DEVEL_PREFIX)include
-$(INSTALL) -m 644 lib/*.[ao] $(PREFIX)$(DEVEL_PREFIX)lib/
- if [ "$(KERNEL_SOURCE)" = "$(DEVEL_PREFIX)" ] ; then \
- extra_exclude="--exclude include/linux --exclude include/asm'*'" ; \
- else \
- extra_exclude="" ; \
- fi ; \
- tar -chf - include --exclude .svn --exclude CVS $$extra_exclude \
+ tar -chf - include \
| tar -xf - -C $(PREFIX)$(DEVEL_PREFIX)
ifneq ($(strip $(UCLIBC_HAS_FLOATS)),y)
# Remove floating point related headers since float support is disabled.
@@ -253,7 +248,7 @@ ifeq ($(strip $(HAVE_SHARED)),y)
$(INSTALL) -d $(PREFIX)$(RUNTIME_PREFIX)lib
$(INSTALL) -m 644 lib/lib*-$(MAJOR_VERSION).$(MINOR_VERSION).$(SUBLEVEL).so \
$(PREFIX)$(RUNTIME_PREFIX)lib
- cp -dRf lib/*.so.* $(PREFIX)$(RUNTIME_PREFIX)lib
+ cp -pRf lib/*.so.* $(PREFIX)$(RUNTIME_PREFIX)lib
@if [ -x lib/ld-uClibc-$(MAJOR_VERSION).$(MINOR_VERSION).$(SUBLEVEL).so ] ; then \
set -e; \
$(SHELL_SET_X); \