1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 21:39:49 +03:00
openwrt-xburst/openwrt/package/pcre/patches/100-honor_cppflags_ldflags.patch
nico 652ac68bb9 add a patch to use cppflags when compiling and ldflags when linking,
it should prevent libtool from linking against host libraries.


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3382 3c298f89-4303-0410-b956-a3cf2f4a3e73
2006-03-15 21:41:50 +00:00

25 lines
1.2 KiB
Diff

diff -ruN pcre-5.0-old/Makefile.in pcre-5.0-new/Makefile.in
--- pcre-5.0-old/Makefile.in 2004-09-13 16:20:00.000000000 +0200
+++ pcre-5.0-new/Makefile.in 2006-03-15 08:28:12.000000000 +0100
@@ -63,6 +63,7 @@
CC = @CC@
CFLAGS = @CFLAGS@
CPPFLAGS = @CPPFLAGS@
+LDFLAGS = @LDFLAGS@
CC_FOR_BUILD = @CC_FOR_BUILD@
CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
@@ -84,10 +85,10 @@
# to do one or the other or both by ./configure.
LIBTOOL = @LIBTOOL@
-LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) -I. -I$(top_srcdir) $(NEWLINE) $(LINK_SIZE) $(MATCH_LIMIT) $(NO_RECURSE) $(EBCDIC)
+LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS) -I. -I$(top_srcdir) $(CPPFLAGS) $(NEWLINE) $(LINK_SIZE) $(MATCH_LIMIT) $(NO_RECURSE) $(EBCDIC)
@ON_WINDOWS@LINK = $(CC) $(CFLAGS) -I. -I$(top_srcdir) -L.libs
@NOT_ON_WINDOWS@LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I. -I$(top_srcdir)
-LINKLIB = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I. -I$(top_srcdir)
+LINKLIB = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -I. -I$(top_srcdir) $(LDFLAGS)
LINK_FOR_BUILD = $(LIBTOOL) --mode=link $(CC_FOR_BUILD) $(CFLAGS_FOR_BUILD) -I. -I$(top_srcdir)
# These are the version numbers for the shared libraries