mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 20:27:30 +02:00
699212b7b4
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18195 3c298f89-4303-0410-b956-a3cf2f4a3e73
50 lines
1.4 KiB
Diff
50 lines
1.4 KiB
Diff
--- a/src/luaconf.h
|
|
+++ b/src/luaconf.h
|
|
@@ -38,7 +38,6 @@
|
|
#if defined(LUA_USE_LINUX)
|
|
#define LUA_USE_POSIX
|
|
#define LUA_USE_DLOPEN /* needs an extra library: -ldl */
|
|
-#define LUA_USE_READLINE /* needs some extra libraries */
|
|
#endif
|
|
|
|
#if defined(LUA_USE_MACOSX)
|
|
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -17,6 +17,7 @@
|
|
MYCFLAGS=
|
|
MYLDFLAGS=
|
|
MYLIBS=
|
|
+# USE_READLINE=1
|
|
|
|
# == END OF USER SETTINGS. NO NEED TO CHANGE ANYTHING BELOW THIS LINE =========
|
|
|
|
@@ -75,7 +76,7 @@
|
|
@echo "MYLIBS = $(MYLIBS)"
|
|
|
|
# convenience targets for popular platforms
|
|
-
|
|
+RFLAG=$(if $(USE_READLINE),-DLUA_USE_READLINE)
|
|
none:
|
|
@echo "Please choose a platform:"
|
|
@echo " $(PLATS)"
|
|
@@ -90,16 +91,16 @@
|
|
$(MAKE) all MYCFLAGS="-DLUA_USE_POSIX -DLUA_USE_DLOPEN" MYLIBS="-Wl,-E"
|
|
|
|
freebsd:
|
|
- $(MAKE) all MYCFLAGS="-DLUA_USE_LINUX" MYLIBS="-Wl,-E -lreadline"
|
|
+ $(MAKE) all MYCFLAGS="-DLUA_USE_LINUX" $(RFLAG)" MYLIBS="-Wl,-E$(if $(USE_READLINE), -lreadline)"
|
|
|
|
generic:
|
|
$(MAKE) all MYCFLAGS=
|
|
|
|
linux:
|
|
- $(MAKE) all MYCFLAGS=-DLUA_USE_LINUX MYLIBS="-Wl,-E -ldl -lreadline -lhistory -lncurses"
|
|
+ $(MAKE) all MYCFLAGS="-DLUA_USE_LINUX $(RFLAG)" MYLIBS="-Wl,-E -ldl $(if $(USE_READLINE), -lreadline -lhistory -lncurses)"
|
|
|
|
macosx:
|
|
- $(MAKE) all MYCFLAGS=-DLUA_USE_LINUX MYLIBS="-lreadline"
|
|
+ $(MAKE) all MYCFLAGS=-DLUA_USE_LINUX $(if $(USE_READLINE), MYLIBS="-lreadline")
|
|
# use this on Mac OS X 10.3-
|
|
# $(MAKE) all MYCFLAGS=-DLUA_USE_MACOSX
|
|
|