1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-22 13:51:09 +03:00
openwrt-xburst/toolchain/glibc-ports/patches/2.6.1/401-mips_bootstrap_gcc_header_install.patch
nico c3c59f4189 [massive] add support for alternative C libraries (currently only glibc/eglibc)
other (related) changes:
 - kernel headers are now installed using "make headers_install" on 2.6
 - target names now contain an openwrt "vendor" tag (e.g. mips-openwrt-linux-gnu)
 - build directory names now contain gcc/libc name/version
 - default cpu for x86 is now i486 (required to build glibc/eglibc)


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13931 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-01-08 01:49:11 +00:00

12 lines
443 B
Diff

diff -ruN glibc-ports-2.7-orig/sysdeps/mips/mips32/Makefile glibc-ports-2.7/sysdeps/mips/mips32/Makefile
--- glibc-ports-2.7-orig/ports/sysdeps/mips/mips32/Makefile 2003-03-29 09:15:28.000000000 +0100
+++ glibc-ports-2.7/sysdeps/mips/mips32/Makefile 2008-10-01 17:04:40.475005748 +0200
@@ -1,3 +1,7 @@
+ifeq ($(filter -DBOOTSTRAP_GCC,$(CFLAGS)),)
ifeq ($(filter -mabi=32,$(CC)),)
CC += -mabi=32
endif
+else
+CC += -D"_MIPS_SZPTR=32"
+endif