1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-22 12:59:53 +03:00
openwrt-xburst/toolchain/glibc-ports/patches/2.6.1/603-powerpc-softfloat.patch
nico c3c59f4189 [massive] add support for alternative C libraries (currently only glibc/eglibc)
other (related) changes:
 - kernel headers are now installed using "make headers_install" on 2.6
 - target names now contain an openwrt "vendor" tag (e.g. mips-openwrt-linux-gnu)
 - build directory names now contain gcc/libc name/version
 - default cpu for x86 is now i486 (required to build glibc/eglibc)


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13931 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-01-08 01:49:11 +00:00

22 lines
815 B
Diff

From: http://sourceware.org/ml/crossgcc/2008-10/msg00044.html
From: http://sources.redhat.com/ml/libc-ports/2007-06/msg00005.html
2007-06-07 Steven Munroe <sjmunroe@us.ibm.com>
* sysdeps/powerpc/nofpu/Makefile: Remove fe_nomask from libm-support.
diff -urN glibc-ports-2.6.1.orig/sysdeps/powerpc/nofpu/Makefile glibc-ports-2.6.1/sysdeps/powerpc/nofpu/Makefile
--- glibc-ports-2.6.1.orig/sysdeps/powerpc/nofpu/Makefile 2006-11-22 09:13:11.000000000 -0600
+++ glibc-ports-2.6.1/sysdeps/powerpc/nofpu/Makefile 2007-06-07 09:53:05.708240976 -0500
@@ -6,7 +6,7 @@
endif
ifeq ($(subdir),math)
-libm-support += fenv_const fe_nomask
+libm-support += fenv_const
CPPFLAGS += -I../soft-fp/
# The follow CFLAGS are a work around for GCC Bugzilla Bug 29253
# "expand_abs wrong default code for floating point"